Touchpad two finger detection is extremely unreliable (linux user)

Is there a known issue with the touchpad’s two finger detection in general for linux? Both click and scroll seem to be undetected on my device. I’m using manjaro linux, and I installed the double sided tape that came in my box.

Anything I could be missing? Is there a firmware update I should install? (also will those arrive via normal firmware updates (eg via fwupd?)?)

Hi Jon, could you try disabling PS/2 Emulation Mode in BIOS to see if that resolves the issue? My touchpad isn't working

ah, thanks @nrp (I searched the forum, but I guess didn’t try enough queries)

hmm… now I’m unable to get to the bios any longer. I seem to recall another thread about that…

hmm… now I’m unable to get to the bios any longer. I seem to recall another thread about that…

ah, found guide that unblocked me via systemctl command, though F2 indeed doesn’t work for me.

could you try disabling PS/2 Emulation Mode in BIOS to see if that resolves the issue?

No change in behavior (to clarify: it was set to “auto” before, and now is set to “disabled” but I’m not seeing any difference in touchpad behavior, in any regard).

My touchpad isn’t working

I don’t see anything else in that article that might help here… unless there’s a driver that I might not have (not sure how I’d get it on Linux).

There are also some suggestions in the thread here around having the right libinput version: (SOLVED, sort of)Touchpad Not Working Fully

To confirm that it’s not a hardware issue, could you try running an Ubuntu 21.04 or Fedora 34 Respin live USB?

tl;dr still no luck; poking my understanding of the other threads though… we’ll see. maybe a hardware issue afterall…

There are also some suggestions in the thread here around having the right libinput version: (SOLVED, sort of)Touchpad Not Working Fully

  • wrt libinput version: i’m at 1.18.1-1 (pacman, this distro being manjaro)
  • There’s a work around posted in that thread, to bring in a local-overrides.quirks file, but it doesn’t work for me

To confirm that it’s not a hardware issue, could you try running an Ubuntu 21.04 or Fedora 34 Respin live USB?

thanks for continuing to reply here, nrp!

omg pebkac, i had “two-finger scrolling” toggle disabled in gnome settings’ “Mouse & Touchpad” UI 🤦😭🤦 Sorry for the noise

I think I disabled it when I was trying to debug the two-finger right-click which is indeed still missing