[TRACKING] Graphical corruption in Fedora 39 (AMD 3.03 BIOS)

Hi there!

I experienced the same graphical glitching (in my case my monitor turned into some kind of strobe), but I noticed it was only when I had multiple thing running:

  • Firefox with a bunch of tabs, including 1 Google Meet
  • Discord
  • Spotify
  • Steam
  • Terminals

As I was still setting up my laptop, I had worked on it just a little bit earlier and didn’t have a lot of programs running (or FF with 20+ tabs).

I did switch my iGPU to GAME_OPTIMIZED mode, which assigns it 4 GB vRAM and then I started up all programs again. It hasn’t triggered (yet?), but I also wanted to check whether or not memory pressure in the iGPU can cause this. So I ran GitHub - Umio-Yasuno/amdgpu_top: Tool to display AMDGPU usage, I think this answers it:

Assuming the ‘normal’ iGPU gets 1 GB of vRAM, my current software workload required a little more then 1GB to run properly. Whether or not that’s desireable or a bug somewhere else, I don’t know :slight_smile:

2 Likes

UPDATE: so I still have the issue, but the occurences have still greatly dimished. The only situation in which I can still encounter this issue is resuming from hibernation (with my ‘usual’ stack of software running).
The solution so far been very simple, just suspend (I use suspend-then-hibernate) and resume the laptop immediately.

Fedora just updated to kernel 6.7. Now I get the ‘Christmas lighting effect’ on my laptop screen

1 Like

What’s the Christmas lighting effect? :nerd_face: seems a bit off-season? :smiley:

There is a bug in kernel 6.7:
Flickering coloured glitchyness on 780M Phoenix iGPU with 6.7.0 kernel on Xorg/plasma (#3097) · Issues · drm / amd · GitLab
Please try this patch linked in there:
https://gitlab.freedesktop.org/drm/amd/uploads/7961021a4cac7db04f50fb99ccaf5b14/0001-drm-buddy-Improve-alloc_range-error-handling-routine.patch

1 Like

hahaha yeah. This is what I’m talking about: flickering and display corruption with linux-next-20230918 and mesa-23.1.{6,7} (#2859) · Issues · drm / amd · GitLab and [RESPONDED] Blocky artifacts on AMD Framework laptop 13 - #7 by Steven_Scheepers

thanks! Is this patch upstream yet?

Thanks for the heads-up then, I’ll wait with the update a bit (maybe not until Christmas though… :wink: )

1 Like

It was just posted an hour ago to the bug. It’s not upstream, but you can test it and if it works you can report that back to the bug to help it land sooner.

1 Like

This is really interesting, because i have the same problem on Arch even with the latest 6.7.3 kernel. It is worse in Wayland than with X11. Both on internal and external monitor. But only with the internal GPU, with an external one, the problem is gone. The “amdgpu.sg_display=0” option mostly fixed it for me but appears to have a substantial negative impact on performance.

As another Arch user, I would suggest to at least experiment with setting UMA_GAME_OPTIMIZED in the bios. Coupled with the 6.7 kernel series, it reduces the problem to a rare event. Moreover, it may be a lesser evil, since it doesn’t negatively impact GPU performance.

The hit on your available RAM isn’t too bad, in my experience. Of course, this assumes that you system doesn’t have a lot of memory heavy daemons/programs running, but as another Arch user, you probably know your way around tweaking/optimizing those. FWIW: I run Gnome, tend to have a lot of tabs open in Firefox, and can easily run other programs alongside these without ever using much more than 11-12GB, though more often, I’m only using 6-7GB.

Also look into using zram to get more mileage out of your available RAM, at the cost of occasionally tasking your CPU a bit more.

I ran zram on a core2 duo for years, the cpu hit is pretty neglible.
Totally made the system usable for me though.

In my experience you really can only gain about 20% more effective RAM before it stops helping.

Still having the issues if I turn off UMA_GAME_OPTIMIZED in the bios.
I hope the 6.7.x kernel will fix it :frowning:

I still get them in 6.7.3 Fedora 39

A little update: Just updated the kernel to 6.7.4 and it has made things worse. The external screen turns white more frequently. I would just permanently set the UMA_GAME_OPTIMIZED option to on.
I don’t know if it’s a hardware or a driver issue, but it’s really frustrating.

3 Likes

Is it safe to say those of us with AMD GPUs should stick with the 6.6.x kernels?

No need to avoid updating. You can just set the UMA_GAME_OPTIMIZED option and it will work fine :slight_smile: . It’s good that AMD is looking into it.

1 Like

Awesome, thank you for this. Is this filed with Fedora if it is not already? It’s brand new it looks like, so I am sure it has not been - asking to avoid duplication.

Not filed.
This is upstream submission.

[PATCH 1/2] drm/buddy: Fix alloc_range() error handling code (kernel.org)

2 Likes

Not sure if this is related here but external displays have started blowing up my CPU usage for some reason, 7640u F39 KDE Kernel 6.7.4-200.