Trackpad Behavior - Move Cursor With One Finger, Tap With Another?

When my AMD FW 13 arrives, It will replace my Macbook Air as my “daily driver.” One thing I’ve gotten quite used to over the years is using the Mac trackpad with two fingers.

I move the mouse cursor with my middle finger and my index finger is hovered just above the trackpad. When I want to “click” I just tap with my index finger without lifting my middle finger. If I want to scroll, I just set my index finger down and then lift it when I want to go back to moving the cursor. This behavior has become completely second nature to me.

When using my 11th gen Framework with Fedora-XFCE, the trackpad will not recognize a tap when another finger already resting on the trackpad. I tried Fedora 38-GNOME from a live USB the other day and it worked exactly the same once I enabled tap to click (won’t recognize a tap to click if another finger is touching the trackpad). I didn’t find anything obvious in the settings to allow this.

I’m sure I can get used to this behavior. I’m just curious if there is something I can change to make this work when setting up my AMD FW13 (Batch 4, so it should be soon!), or if it’s just a difference I’ll have to get used to.

I don’t think this is solely a Framework hardware issue, rather it is just the state of Linux support at the moment. There is a lot of software development that goes into what makes apple trackpads so great to use, in addition to their hardware. I have chosen to just live with it as it’s not great, but it’s “good enough” for mobile use.

1 Like

Thanks. I didn’t really figure it was a hardware issue. Just wasn’t sure if there was some simple setting or maybe an add-on that changed things. Not a big deal. I got used to one way I can get used to another.

Seems like the Framework hardware is capable of this, just tested on Windows 11 and I can do it no problem.

I suppose if Linux doesn’t have any support for this, I’ll just deal with it.