[RESPONDED] Two fingers scrolling sometimes triggers a right click

Hi,

I have a great FW13 AMD (batch 8) rurning on Ubuntu 23.10
I have an issue I have trouble to diagnose : when I scroll with two fingers, if I pause (with the two fingers still on the touchpad) it sometimes trigger a right click.
The key issues for me is the “sometimes” : I have not been able to understand the exact conditions needed to trigger this - but it happens quitte often.

Additionnal information :

  • Natural scrolling is set
  • Palm control is disabled
  • No additionnal modification have been done to the touchpad config
  • Kernel 6.5

Has someone else witness the same behavior ?

Thanks,
Clément

Hello @Clement_Marche ,

Just to rule out if it has something to do gnome config or the underlying hardware, can you check if it also happens with Ubuntu 22.04.3 live? or with Fedora 39?

cheers! :slight_smile:

1 Like

Sure good idea. I’ll work on that on the next few days and come back with the results.

Hi, checkin in on this topic : since I posted this I have tried to reproduce it with a Live Ubuntu + a clean profile on my existing Ubuntu install but no luck.

Something strange is that I have not noticed the behavior on my standard profil as well.
I’ll update the topic if it comes back (and I keep an eye on this topic because it looks like the same issue).

Interesting. I use an Intel 12th Gen FW, and sporadically experience similar issue. However, it always trigger at the beginning of a scroll.

Oh, editor just alerted me you’ve found my post. Small world :slight_smile:

I’ll find a time to install an OS on my spare Framework, to further test if this is due to individual out-of-spec touchpad. (I might also just order a replacement touchpad if I feel that becomes necessary to further unmask the cause)

1 Like

Update: Left my laptop lid closed for long enough that it entered hibernation (expected Windows behavior), after waking from hibernation my version of this issue can no longer be replicated. Appears to be consistent with my memory of a restart temporarily makes this issue go away, as I stated in my own post.

I still don’t know if it’s the touchpad gradually going out of spec when powered on, or malfunctioning driver. I suppose hibernation saves many states, including drivers that are running, but does power-cycle all hardware. (so I’m kind of leaning toward the touchpad itself?)

In any case, I installed OS on my spare Framework, and wasn’t able to immediately replicate this issue on that unit. I set it to never sleep and is currently on, which will allow me to test if that touchpad will begin to exhibit similar issue after long period of on time.

I also yoinked the touchpad from device manager on my daily Framework, the one that is experiencing this issue, and reinstalled driver bundle.

Therefore, if my spare Framework still doesn’t exhibit this issue after been running for a long time, and if my daily Framework experience this issue again even after yoinking and reinstalling touchpad driver, I’ll likely order a replacement touchpad.