Trackpad doesn't work after wake from sleep

Sometimes when I wake my laptop from sleep, the trackpad doesn’t work. Moving it around does nothing. I saw from this post that disabling PS/2 emulation should fix the issue, but I’ve done that and it’s still happening.

OS: ArchLinux
BIOS Version: 0.3.07

I have it disable as well as I have this:

#!/bin/bash

case "$1" in
    pre)
        /usr/bin/echo "touchpad-suspend-workaround: unloading i2c_hid" | /usr/bin/tee /dev/kmsg
        /usr/sbin/rmmod -s i2c_hid
    ;;
    post)
        /usr/bin/echo "touchpad-suspend-workaround: loading i2c_hid" | /usr/bin/tee /dev/kmsg
        /usr/sbin/modprobe -s i2c_hid
    ;;
esac

in /lib/systemd/system-sleep/touchpad-suspend-workaround

3 Likes

I’ve noticed sometimes before that the sensitivity on it is extremely high too, others have also reported this issue.

Thank you! Hopefully Framework knows about this and is trying to fix it.

Note that this is where the file belongs on Ubuntu. Not sure if it’s the same for Arch. Adapt as needed.

This is basically the PS2 emulation kicking in due to the same problem. If you have PS2 emulation disabled, the trackpad would simply not work instead of changing speed.