Ubuntu 21.04 on the Framework Laptop

Ok, I’ve confirmed that it is set to deep sleep.

Testing again, after 12 hours of sleep it dropped from 100% to 81% (~1.6%/hr).

4 Likes

Excellent, glad to hear that. Feel free to edit the wiki post (first post in this thread) with that.

1 Like

To enable deep sleep on Ubuntu 21.04 (kernel 5.11)

  1. Find the following line in the /etc/default/grub file:
    GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash"

  2. Change it to:
    GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash mem_sleep_default=deep”

  3. Run sudo update-grub

  4. Reboot
    a. To verify, run the following from the terminal:
    cat /sys/power/mem_sleep
    b. If the output is s2idle [deep] then deep sleep is enabled (note the brackets are on “deep”)

9 Likes

Hi, I accidentally installed Kubuntu version 20.10 instead of 21.04, and I can’t access the internet (presumably because the version number is too low). What’s the best way to go about trying to fix this? I can’t do any updates since there is no internet connection, and when I tried to install a higher version number with a flash drive using the same technique of holding F12 I don’t go to the one time boot menu, but rather the startup web page.

1 Like

The startup key timeout is set to 0 seconds by default which doesn’t give much time to use F2 or F12.

Try running this command from terminal to reboot straight to the BIOS:
sudo systemctl reboot --firmware-setup

Then either change the Timeout to something higher or change the boot order (with the 21.04 installer is plugged in): BIOS guide

4 Likes

Has anyone figured out two-finger right clicks in Ubuntu 21.04? Currently, I can only right click by single finger-clicking in the lower-right-hand side of the trackpad.

I’m doing two-finger right-clicking in 21.04 right now. I didn’t have to do anything to make it work. Just tried it in a few different places/apps. Works. Wish I could be more helpful, sorry.

Double-check the mouse mode in the BIOS/EFI settings. Maybe the “auto” mode is not detecting correctly.

I got it fixed - I installed gnome-tweaks and there was a setting there for two-finger right clicks. Enabled it and it started working immediately!

sudo apt install gnome-tweaks

2 Likes

Thank you very much @jeshikat! I successfully installed Kubuntu 21.04 with internet working (haven’t tested it much though). It took a few tries after setting the timeout to get the usb to work, not sure if it’s because of the issue mentioned in the header post or because I was holding the key at first instead of pressing rapidly. Also the first time I tried to boot the usb drive the screen went black and didn’t make progress, after waiting a hour I turned off the device and tried again to great success.

That was likely the problem. Once you know to repeatedly tap the key it’s fairly straightforward, but honestly I prefer the Mac method of just holding a key right after startup.

The screen going black is odd, but if it’s working now that’s good!

I installed Xubuntu 21.04 on my DIY edition (i7, “no vPro” wifi), and it went mostly very smoothly. However, the biggest issue I have is that it comes out of sleep in a randomly broken state, usually to do with the mouse: things like not taking input anymore, or the speed getting really high and things like the scroll gesture stop working. I’ve not had a chance to do much deep diving into that yet, but next time I’ll check the logs for anything fishy.

The other issue I’m having is that the brightness controls aren’t doing anything, and I can’t even get a sensible looking key event in xev, but it’s possible that something is wrong with my i3 config, and if I were in xfce things would be better there, but I’m not sure; will check that too.

2 Likes

Made an account to chime in on this. Resume after suspend, randomly, will get in a broken state as described above.

I enabled the S2 deep workaround, and am running root ZFS encrypted. Otherwise totally stock Ubuntu 21.04 (wayland enabled).

Anyone else? I’ve had to shut down the machine instead of sleeping for now.

1 Like

I installed Ubuntu 21.04 today. According to mem_sleep mine is defaulting to deep. Verified I don’t have the setting in the /etc/default/grub. Not sure why I am seeing a different behavior. Probably worth checking step 4a before doing the rest.

1 Like

Is it showing [s2idle] deep or s2idle [deep]? Just double-checking because someone in the Fedora thread got it backwards.

You’re right! I was looking at the words and not which ones were in brackets. It was showing [s2idle] deep. Thanks for that!

1 Like

Updating with my findings: after disabling deep and letting it go back to s2idle, I no longer have issues with resume.

Unfortunately the battery drain issue is back when disabling [deep]. It sounds like I’ll just have to keep it plugged in while asleep until this bug is fixed.

Right, I got it backwards, and people were polite and helpful in correcting me. For the uninitiated, it’s not obvious how to interpret that string. Here’s how I understand it now:

example of deep sleep disabled:

[jeremy@fwfedora ~]$ cat /sys/power/mem_sleep
[s2idle] deep
[jeremy@fwfedora ~]$

example of deep sleep enabled:

[root@fwfedora ~]# cat /sys/power/mem_sleep 
s2idle [deep]
[root@fwfedora ~]# ```
2 Likes

Deep sleep does not seem to be working with encryption enabled.