Ubuntu 21.04 on the Framework Laptop

Thank you for the alternative.

Nice to have choices.

I installed 21.04 on my batch 6 Framework last night. I’m having 2 problems, both related to input lag.

First, I had an issue where my mouse cursor would briefly freeze, then jump to where I had move it… happening every minute or so. Google led me to the solution which was to switch from Wayland to Xorg, that seemed to fix it. So far so good.

Second, I’m having input lag related to keyboard input. It’s subtle, but I’m getting delay I’d say of 500ms maybe? Give or take. Sometimes it’s worse. It just feels slightly off. Happens everywhere - terminal, text editor, etc. This may be more of a linux problem than anything, but curious if anyone else has seen this or had these issues.

The (very irritating) mouse cursor sticking/lag is a know issue, and fixed in newer kernel versions (5.14.x onwards).

I’m using Ubuntu 21.10, and with the default 5.13.x kernel has the same mouse cursor issues.
Installing the 5.15.6 kernel solved it for me. You can install the newer kernel on 21.04 if you don’t want to update to 21.10.

Installation instructions here, listing of all kernel files here, and the files for 5.15.6 specifically here.

[Note: I’m stuck with 5.15.6 because the 5.15.7 and 5.15.8 kernels don’t cleanly install because of has an unmet dependency [libssl3 >= 3.0.0], so I’m guessing they used 22.04 [Jammy] to compile those kernels… which is a pain… ]

I haven’t noticed the keyboard issue, so I don’t have any advice on that…

1 Like

Recognition of a newly connected USB disk is inconsistent. I am running Ubuntu Studio 21.04 (based on Kubuntu) with a 5.11.0-41-lowlatency kernel. Unplugging power has always tickled the system to notice the disk. When unnoticed, the disk does not show up as a /dev/sd***. Once it shows up on /dev, automount works reliably.

There could be a hardware problem involved, but my first suspicion goes to the OS. I had similar issues some years ago with a different version of Ubuntu on a Lenovo ThinkPad, then it cleared up for some years.

I also had one spontaneous unmount while using a USB disk. That could be due to a slight disruption of the cable, so I won’t take it too seriously unless it happens a few more times.

This is the sort of thing that I may never diagnose properly, and it may go away with some future system update. But, if anyone else has the same experience, we should pool our information.

I had this issue on 20.04. The only way I could get a USB drive to mount was to either have it attached to the system at power on, or for it to have its own power switch that I turned on after plugging it in. I moved to 21.10 and haven’t had the issue since. According to uname, I’m running 5.13.0-22-generic.

I’ve tested quite a few different USB thumb drives on Ubuntu 21.10. So far I have only found one drive model to have intermittent problems, and it worked fine when going through a USB2 hub. I’d try that just to double check. Also check dmesg.

For reference: Device Incompatibility: Kingston DataTraveler Duo

Hi everyone, I’m running Ubuntu 21.04, and up until today, the wifi was working fine. Today it is not working at all. I believe I installed this latest wifi driver. When I live boot from the original 21.04 flash drive I used for installation, the wifi works fine. Can anyone help me figure this out? I’m a new Linux user and first-time non-Apple hardware user with the Framework, so thanks for your understanding and any assistance!

@j-s, if it was working until today, did you upgrade or change anything? I would start there, also take a look at the logs and see if they point to what is causing the wifi not to work.

I’m running ubuntu 21.10, kernel 5.13.0-22, and also having the headphone mic problem, as reported by @Jay_Sekora above in comment 105.
I tried installing kernel 5.15.6 as suggested by @EdgeCase to resolve the sticky mouse issue, and to see if that fixed the mic problem, but when I reboot I get the message “can’t find command ‘hwmatch’ file linux-(can’t remember which one).deb has invalid signature.”
When I check the checksum file using
gpg --verify CHECKSUMS.gpg CHECKSUMS
I get

gpg: Signature made Mon 18 Oct 20210o 01:32:12 AM MDT
gpg: using RSA key E50C6A0917C622B0
gpg: BAD signature from “Kernel PPA kernel-ppa@canonical.com” [unknown]

The files do seem to validate ok using:
shasum -c CHECKSUMS 2>&1 | grep 'OK$'
but obviously that’s suspect given the problem with the CHECKSUM files themselves.

Hints on where I screwed up?

Edit: I’ve attempted to restore hwmatch.mod using
cp -p /usr/lib/grub/i386-pc/hwmatch.mod /boot/grub/x86_64-efi but that didn’t change anything. How do I get a normal/default boot environment back?

Using apt purge on the 5.15.6 files and rebooting restored the normal boot process. It would be nice to know what was actually wrong with the boot configuration.

The CHECKSUMS issue was because I originally used the CHECKSUMS file from the main download directrory, not the architecture-specific subdirectory.

Delighted to report that after upgrading to 21.10, the microphone on a TRRS headset shows up and works normally! So for me at least upgrading to 21.10 solved this problem and didn’t introduce any new ones [EDIT: except for needing to hold the power button to power off fully]. (I did disable panel self-refresh in Grub after the upgrade, and I had already disabled trackpad PS/2 emulation in the BIOS.)

1 Like

This fix appears also appears to get rid of static with just regular headphones (No Mic) in Ubuntu 20.04 LTS (Zorin) at least after first restart. Gonna do some long term testing to make sure. But thanks for tracking this down.