USB-C footprints

I’m trying to find the proper set of footprints and models for the USB-C plug can anyone lead me to them, I can find the model but not the accompanying footprint. For the time being, I have to use a different one as there are issues with the currently supplied footprints.

Hi Josh, were you having issues with the footprints that are in the project provided in the GitHub repo?

Yep, if I create a schematic and assign footprints I cannot find the USB-c connector I have already specified the expansion cards .pretty folder as a library. I have tried different methods using applications like library loader but can only find the 3d model and cannot request all other parts.

The footprint here should work:

Let us know if you run into any issues with it.

All good, I think there were conflicting files causing the footprint to glitch.

Once again having issues with routing tracks, if I try to wire up the pads it seems as if there is something blocking it.

Perhaps the track width/spacing rules you have configured are too big to fit with the pads properly?

I’ve tried the minimum (0.2mm) to no avail.