USB-C to Displayport cable not working

Hi all - as in the title, and I am running windows 11.

The cable I am using:

I just get an error like this:

Not entirely sure if there is something obvious I am missing, I have tried it on multiple displays with the same result. The cable works without issue on a dell XPS 15 (whichever model was on sale in 2018) via its TB3 port.

1 Like

Heya! No worries, you’re not missing anything obvious. :blush:

First we’ll do the simple things, if you haven’t already maybe try these:

  • Plugging the cable in reversed, in both the laptop and screen. (I’ve had this happen so many times it’s insane!~)
  • Plugging in the USB-C expansion into a different port.
  • Plugging in the cable straight into the expansion bay USB-C, not a card.

If these don’t work, try:

  • If you haven’t already, update your bios / firmware: see @Cleber’s post
  • If you’re kinda familiar with linux, try booting from a live CD and then checking if that works.
  • As a last resort, maybe reinstall windows?

Hope this helps! - If it doesn’t, don’t be afraid to reach out again :orange_heart:

This is an old BIOS, find the most recent one here for 11th Gen processor or here for 12th Gen processor

1 Like

Hi Cheese, thanks for the suggestions.

I am running a 12th gen batch 1 i5-1240p, no new BIOS available for 12th gen yet.

The cable is USB-C to DP, DP can’t be reversed however I have tried the USB-C end both ways without any luck. I have also tried all the ports, with and without expansion cards.

The only thing left is to try linux.

Are there any BIOS settings worth changing from stock settings?

1 Like

Just thinking here, is the Dell laptop on Windows 11 too? :thinking:

no windows 10. can’t upgrade as its a work issued machine