What dock are you using for your FW16?

I’m trying to find a dock that can hopefully work well with the FW16. I currently have a Lenovo Thinkpad Thunderbolt 3 Workstation Dock Gen 2 that’s capable of delivering 230W to a Lenovo laptop, but it can’t do this with Thunderbolt 3 alone it would seem. Is anyone trying other docks? Also, do you know of any thunderbolt3 docks with potentially passthrough power so I can plug the PD charger into the dock, and the dock into the laptop?

This thread may come in handy:

EDIT: I don’t think there is much FW16 specific data there yet, but I’m keeping an eye on it

1 Like

The company I work for is currently using a combination of Lenovo and Dell laptops with a sprinkling of HPs that haven’t been replaced yet. From what I have seen you will be able to use the Lenovo dock for passing through video and USB, but you won’t be able to pass power. I have seen some Lenovo slim tip to USB C adapters on Amazon and other places, but the one I got and tested didn’t work correctly and I would be hesitant to try on my FW16 when I get it. I have had some success using a Dell workstation dock ( Dell Dock – WD19S 180W I think) powering other brands higher teir machines as it uses 2 thunderbolt connections to power the machine. It isn’t perfect and Dell says it won’t provide the full 180W to non Dell laptops, but this is what I plan on trying to see if it will provide enough power.

1 Like

I use a Lenovo dock with HP laptop and power works fine, and I totally expect to use with my FW16 - it only does 60W though.
//edit it does work fine

If you are not using the GPU module then yes the Lenovo dock should work fine. If you are using the GPU module then the Lenovo dock is not going to be able to provide the full 180W that the fw16 uses. So the unit will not be able to maintain the charge while the GPU is in use. If you are just on the desktop browsing the internet or some other non graphics intensive task the Lenovo should be able to maintain the current charge.

Note that passthrough power usually means lower power than was fed to the dock, since the dock needs power itself. Even if it was setup to accept 180W power (which I doubt any passthrough docks are), it would probably only provide 140W when paired with the Framework charger.

Hello hello, I’ve just received my DIY edition 7940HS without dGPU and I have a Dell WD19TBS Docking station that works like a charm ! It charges and my 10Gbit/s ethernet TB3 adapter plugged into the dock works perfectly.
I’ve ordered the 180W power supply as well and I noticed some difference of course. About twice the power that the Dell can deliver. (100W max for the Dell for non-dell devices).
I’ve try to plug my Anker powerbank (it delivers 140W max through one usb-c port) and it shows 132W, pretty happy.
I’m now waiting for the battery expansion bay :wink: to be announced !

Edit : I ran to an issue after the laptop was resuming from deep sleep while still connected in tb3 to the dock. My Owc 10Gbit/s adapter (plugged in tb3 into the dock) wasn’t recognized anymore. I had to unplugged the dock from the laptop. Even when I unplugged the eth adapter from the dock it didn’t work. (all the usb and display port was working just fine).


I have a Belkin Thunderbolt 3 Express Dock HD and it works under windows, although doesn’t deliver enough power to keep the Framework charged so also need to use the power brick.

Unforutnately under linux I get a system freeze while it’s plugged into the dock with external monitors. Computer resumes once I pull the plug out.

Hi mate,
how do you see how much power the docker negociates? (delivers)?
I have the WD19TB here and that one works almost perfectly fine.
Only drawback is - I can’t use the power-on button on the dock, and it is always a matter to remove the usb-c from the FW-16 and plug it back in to get the external screen to show a picture. Any advice on that?

Note: I have the laptop in a laptop stand, closed and only take it out when I move.
Note2: I configured the FW-BIOS to boot automatically for when the power is applied and it is powered down (as a workaround)

Using Fedora 39.

I have the Razer TB4 dock, and USB devices are working fine but monitors don’t seem to work properly. Power delivery is also working as expected.

I have two monitors plugged into it, using USB-C → DP via alt-mode, detected as “unknown display” and outputting at 640x480. No idea why. When I plug these cables directly into the FW16’s USB-C ports, it displays fine. Such a shame :slightly_frowning_face:

If anyone has any way to get this working it would be appreciated!

I’m pretty sure DP is borked right now in the Linux kernel. I hope I’m wrong, but I can’t get DP to work properly either on my Lenovo Thunderbolt 3 dock. Also Fedora 39

Out of curiosity, can you test something for me? Plug the DP monitors into your FW16 the way that worked, and power off the machine completely. Then just power it back on. Do the monitors work when you do that? Mine fail to turn back on with the laptop and it also screws up the laptop monitor until I unplug the monitors for some reason

No that works fine for me, sorry. Just the dock is the issue.

1 Like

Actually that’s great to hear. It seems then that very few docks actually work, so it may be time to get that FW16 dock thread going like we have for the 13

I have gotten myself the ICY BOX USB4 dock (it seems to be a rebrand of this Plugable unit) and it has been working flawlessly. The dock does get pretty hot to the touch to the point where I can confidently say it can be used as a way to keep drinks warm for longer. I have never before had a TB3/4 or USB4 dock before, but from what I read, a dock being hot seems to be normal behaviour as they’re designed to run at high temperatures.

Power delivery at 100W seems to work without issue. The CPU is easily pulling 45W while under stress.

The 2.5Gb Ethernet Port is also recognized as such. Its a “Realtek Gaming USB 2.5GbE Family Controller”, so it runs over USB instead of PCIe, but that shouldn’t be an issue at all.

I am currently running a 1440p 144Hz LG 27GP850-B monitor with it and have no issues. I do not have any other monitor to test the 2nd port with, but it seems like the capabilities of the ports go down if both are in use. 8k30fps when a single port is in use and 4k60fps when both are in use. Sadly don’t have anything to test these claims with.

Besides that I have noticed only one tiny issue with Firefox where it flashes white and until I move my mouse cursor or click on it, it stays white (on both the external monitor and framework’s internal display). Here is a video I managed to capture.
I am unsure if I should blame this on the dock or AMDs drivers being weird as I have gotten a reply in the Framework Discord server from a different user about that weird flashing and for them it was just a matter of adding some kernel parameters on Linux, which I sadly cannot do on Windows. I have also tried installing latest AMD’s drivers instead of Framework’s and that seems to have decreased the frequency of this issue appearing, but it did not fix it, which makes me believe that this may be an issue on AMDs side and not the dock’s fault.

What also seems to happen is that my Focusrite 3rd Gen Solo seems to really rarely just cut off and the audio doesn’t come back until I re-plug it. (even though the audio device is visible in windows). UPDATE: This is on Focusrite and their drivers, using builtin basic microsoft or older Focusrite drivers works flawlessly.

Hello, I have no idea how much power the Dell WD19TBS delivers exactly, I’m just assuming that it is about 100W or less (for non-dell devices it is pretty common). About the powerbank it has a little screen that displays the current output wattage by port.

Docs say only Dell devices will receive 100W. Others less. 60 I think.

Actually the 180W version will delivers 130W to dell compatibles devices and 90W to non dell.
I refer to this documentation.

1 Like

I have the WD19TB without S. But thx for clarifying.

1 Like

I’m on Fedora 39
I use this cable matters usb4/dual DP dock, and everything works great except power passthrough with the 180W FW charger. PD Passthrough with my other chargers (45w, 65w) works though.

Dock is connected to 2x4k/60hz monitors, several usb periphilals, ethernet, and sometimes 10Gbps usb storage.

When using the FW charger through the dock I get system stuttering and high CPU usage until unplugged. Happens on Fedora, Ubuntu, and Windows.

I ordered a 100w charger, will see if I have the same issues as with the FW 180w