FW13 AMD 7840u + thunderbolt 3 dock (Dell TB16) issues

Has anyone else been using a Dell TB16 dock successfully with their new AMD Framework Laptop 13 and Windows 11 Pro?

This morning, I tried plugging in my TB16 dock with two external displays (one 4k and one 1080p) to the left rear USB-C port for the first time. It initially recognized two new displays but the little LED on the cable is not lighting up like it did with my Dell XPS13 9360 laptop before it.

I did a Windows update to the 23H2 version and upon rebooting, the monitors didn’t come back. I was getting power from the TB16 dock but couldn’t see any of the Thunderbolt hubs, ethernet port, etc.

Then I did the AMD 7840u updates via their Adrenaline installer, followed by the Framework Bios 3.03 update after reading that some people’s display and power issues were better with drivers/bios updates, and initially on the first boot after the 3.03 bios update, the only USB port that was working was the right rear port, but a full shut-down and reboot seems to have brought back function to all 4 ports, somewhat.

Unfortunately, the TB16 in the left rear port was only providing power with no displays after the reboot. I unplugged and re-plugged the TB16 and then I got my external displays, but the laptop was running on battery. I had to plug a 65w power supply into the right rear USB-C port.

I need to actually get some work done, but I will report back if I can figure out a solution/scenario where the TB16 is recognized and works more reliably, but it seems to be a coin flip right now of either providing power or external displays, but not both. (the TB16 is powered by the larger 240w power supply, so should have enough for pass-through PD in addition to driving the displays)

1 Like

Have you tried updating the firmware of your dock? Only other thing I can think of. I know that my (admittedly newer) WD22TB4 works perfectly.


I updated the firmware of the dock about 6-12 months ago but hadn’t checked to see if there was anything new. I’ll try seeing if it needs a reinstall tomorrow.

Good to know you have a dock that works as I may have to buy something else (sadly I have two TB16s that worked fine with my dell 9360).

The dock is still authorized with the framework?

I can’t seem to find a way to authorize the Thunderbolt connection in Windows 11 (Thunderbolt control center is only for Windows 10, right?).

But I do see that the system is recognizing it in Settings-> Bluetooth & devices → USB-> USB4 Hubs and Devices:

But I also found this thread (https://www.dell.com/community/en/conversations/xps/tb16-dock-not-charging-non-dell-laptop/647f86e2f4ccf8a8de60210b ) which suggests that the TB16 can’t provide more than 60W power delivery to non-dell laptops. When I plug in a separate power-supply it’s negotiating 60w PD, so I don’t see why it wouldn’t work, and it was actually supplying power to the laptop before I got it to recognize my external displays on power cycling the dock.

I’m probably going to have to try something else, like the 22WDTB4 that was mentioned as working above.

Did you update your drivers before (or after) running the BIOS update? there is a new driver pack that you should have installed before the update.

On my HP laptop (with Windows 11), I still needed to download Thunderbolt Control Center and authorize the dock from there. Thunderbolt Control Center - Microsoft Apps

I have avoided win11 so far but no authorization → no thunderbolt (unless you set it to insecure mode but I am not sure windows even lets you do that anymore, and you kinda should not anyway) so you do need to get it authorized somehow. Maybe try the win10 version of tb control, not like win11 is that different under the hood.

The TB16 looks like it has one of the older tb3 chip-sets that can’t fallback to usb+dp mode when thunderbolt doesn’t work.

Yes, this is all pretty strange. I installed the Thunderbolt control center app linked above, and it doesn’t find any devices, and the “Controller driver version” is listed as N/A in the about pane:


But in device manager, it lists two Thunderbolt 3 routers:

And my two external monitors plugged into the dock work, which would suggest that it’s using TB3 if the TB16 isn’t supposed to be able to fallback to USB+DP mode?

I’ve re-run the 10/24/23 Framework driver installers with no change in behavior (still no USB-PD power via the dock cable, and the little LED doesn’t light up on the cable).

The Thunderbolt app is not likely to find anything because Intel is looking for a Thunderbolt-certified driver that works with Thunderbolt-certified ports on the PC.

Because the FW13 AMD is USB4 and is not Thunderbolt-certified, I’m not surprised the Intel app isn’t helpful at all.

Edit: Per the Microsoft developer info page on USB4 devices, it seems like it should be showing as a USB4 Root Device Router using USB4DeviceRouter.sys for all “USB4 and Thunderbolt 3 hubs and devices”. Not sure why yours is showing as a Thunderbolt 3 Router.

Mine is slightly different from what Microsoft says though. Microsoft:


Unless my quick research is wrong and that thing is capable of falling back to usb+dp mode, having displays working on the dock means thunderbolt itself works.

I do have the USB4 Root/Host Routers listed also, in addition to the Thunderbolt 3™ Routers:

But I think I’m giving up on the TB16. I had to reset the TB16 (unplug, hold power button on dock for 30 seconds, then replug power to the dock and the cable to the laptop) and restart and unplug/replug the cable 4-5 times this morning to get my external monitors to show up.

Someone noted that their Lenovo 40B0 Thunderbolt 4 dock was working well and I found one on ebay that should arrive tomorrow or Monday.

Thanks for everyone’s help and suggestions! Glad to have joined the community…

Dang- I had an eBay best offer which I thought had been counter-offered/declined for a Dell WD22TB4 outstanding when I purchased the Lenovo 40B0, and somehow my offer got accepted, so now I also have a Dell WD22TB4 on its way as well. (I did have two TB16 docks for two work locations, so not the end of the world to have two docks if they both work, I guess.)

At least I’ll be able to report back if any issues to help others looking for compatible docks.

Just to close the loop, both the Lenovo 40B0 and the Dell WD22TB4 docks seem to be working well for me with a 4k displayport monitor and a 1080p HDMI monitor, and a few USB devices (external keyboard, USB microphone, logitech universal receiver), and both provided 60w of USB-PD. The Dell has a little LED on the plug which stays lit when the laptop is on.

After using the Dell for a week, just today I started having 2-3 episodes where the 1080p screen went black and then came back after about 1-2 seconds which I haven’t done any troubleshooting on yet. I used the Lenovo for about 2 days, and might actually like that one better because it appears to be fanless and has a removable thunderbolt cable to the host, unlike the Dell dock, but still trying to decide which dock will stay on my primary workspace, and which will go to a different setup.

Hey guys, I know this thread is a little old, but did you have to do anything special to get the USB4 Root Router to show up? I have a 7840u, have installed the framework drivers and the AMD drivers and those don’t show up for me.

I’m having issues getting an eGPU to fully function, so was wondering if there are some drivers that I am missing. Are those only displayed when the dock is plugged i? or are they like the USB Root Hubs that are just always there?


Just unplugged my dock and went to device manager and the USB4 Root Router and USB4™ Host Router (Microsoft) entries were still visible (I did not have “show hidden devices” selected in the view menu), but I think the “USB4 Router” showed up after I plugged my dock back in.


Which eGPU are you using? I have a Razer Core X with a NVidia RTX-3090 that I haven’t tried to get working yet (hoping to play with some local LLMs when I get some time one of these days). I’m a little worried that installing the nvidia drivers will introduce some more instability in Windows though given the AMD discrete graphics (occasionally getting a complete lockup on the Windows 11 lock screen after waking up the screen) and still trying to decide whether I want to try and install/access it via WSL or natively, or just dual-boot linux and use it there when needed.

Hmmm; I don’t have that as an option. Did you install anything special for Thunderbolt?

I think when I was troubleshooting my Dell TB16, I downloaded and installed a “Thunderbolt Control Center” app from Intel.

If I recall correctly, I was having trouble finding how/where to authorize the Thunderbolt dock in Windows 11, but I can’t remember if it worked and was actually helpful, given that the TB16 wouldn’t provide USB-PD power via the thunderbolt cable, even though I was getting two display outputs and USB ports working.

And you installed the same Thunderbolt Control center on the framework as your dell?

I’ve installed that on the framework but I don’t get any devices to show up. Even as I’m typing this using the eGPU, it doesn’t show up as a thunderbolt device. It does on my intel laptops, but on the framework nothing.

eGPU is an Aorus gaming box btw; I’ve gotten the eGPU part working but now the USB ports attached to the eGPU aren’t being detected. More of an annoyance than anything else, but would be really nice to get the whole package up and running as everything else about the laptop I’m really digging.

A little OT: Could any FW AMD owner please upload a screenshot of the Windows 11 USB4 Panel?

I have been asked to prove that AMD is limited to a single DP connection per USB4 port, but cannot find any existing screenshot showing this.

For reference, this is the panel I am talking about on an Intel/TB4 machine, where it shows that as required by TB4 2 DP connections are available and I believe AMD to only offer a single connection.