Win10/11 High GPU utilization at idle?

Hi! Long time listener, first time caller, love my batch 4 Framework.

Intel Power Gadget shows this laptop at about 88-90% GPU utilization constantly, without opening a single thing. Fresh boot, only thing running is IPG, runs just as high as Chrome with a half dozen tabs. Windows 10 and Windows 11. Haven’t tried Linux yet.

Long time Mac guy, haven’t used Windows since 2012, unsure if this is just “how it is”, but it seems a bit unwarranted.

Any ideas?

Thanks in advance- Greg
1185G7 / 32GB

This seems wierd to me. How about confirming the reading with a different monitoring tool? Built in Task Manager in advanced view or HWinfo should do.

I don’t really expect it, but maybe it’s just the Intel Utility that has an issue here. Also, are you maybe using an external display?

Great thinking on the second diagnostic source. Advanced task manager shows it as basically nothing, so I’m guessing there’s some kinda bug in Power Gadget. Which is far more preferable than a working utility and a pegged GPU.

And no external monitor, no nothing. Fresh boot, no weird hardware, expansion cards are 2x USB-C, 2x USB-A.

Anyways, thanks for the advice, and sanity check. :+1:

1 Like

Ha, bit surprised but happy to hear that seemingly it’s just a monitoring issue.

The reason I was asking for external displays: I know from own experience that driving multiple displays with not nicely divisible framerates (e.g. 60 & 144hz) might cause a GPU to stick to a higher power state.

1 Like

Yea, that level of extended hardware workload, I can totally understand that leaving a GPU at a higher state, even without much, or anything running.

Which I guess is partially why this was confusing for me. The Framework didn’t seem to be running too high or too hot, despite showing me about a 90% GPU usage. These days, it’s a lot of “on my lap, sitting on the couch”, and it’s not nearly warm enough to worry about. That’s what made me wonder if this was a common Windows thing. Glad it just seems to be a bad reporting in a small monitoring utility.

Anyways, thanks again for an easy, logical second metric.

I’ve had the same issue and tracked it down to Windows Photos app that starts indexing files while I’m away from the laptop. Goto Photos’ settings and remove all folders that it sees as “collections”. Additionaly you may want to disable other features as well (people AI face recognition, network shares indexing, etc)

1 Like

Very interesting, I’ll check that out this evening. Thanks for the note!

1 Like

The Intel power gadget could still be correct and just using 90% of the available cycles for calculations - at 100 MHz (idle frequency iirc). I would place my trust in Task Manager and hwinfo64 however.

1 Like