Windows 11 - no trackpad gestures or right click

I got my 12th gen batch 2 laptop yesterday. Installed Windows 11 Pro from a USB stick first. Right away the trackpad did not have a right click or two-finger scroll. Ran the Framework driver update first (Framework Laptop BIOS and Driver Releases (12th Gen Intel® Core™)), then all the available Windows updates. Still no go, so I ran the Framework driver bundle again. Restarted several times in the process. Still no right click or scroll. Also installed Fedora 36 to dual boot - all trackpad functionality works fine in Fedora. What am I missing? Feeling dumb, and a little frustrated.

Edit: Also the brightness controls don’t work on Windows. Didn’t test in Fedora yet.

1 Like

Hmm I had the same issue but it was rectified by installing the driver pack. You might have downloaded the drivers for win 10 rather than the new win 11 ones…

Good point. I hadn’t double-checked that. But looks like I got the right one.

Maybe I need to run it a third time, third time’s the charm and all…

I realized that I also have an old 11th gen machine so you might have a completely different issue. Hopefully someone with a 12th gen machine gets online and can help you.

1 Like

The date on that driver bundle doesn’t match the one on the drivers page you linked upthread.

You’re installing a driver bundle with the datecode 2021-12.
2021-12 predates the 12th Gen laptop by quite a bit!

The driver on the page you linked is marked with the datecode 2022-07.

1 Like

Thanks for noticing that. I’ll try that one. I’ll note however that the one I downloaded was by following links in the 12th gen setup guide on Framework’s site. So an honest mistake.

Ok, I was a little dumb. Somehow I got on the 11th gen page and didn’t notice it. So I installed the wrong package. Mouse stopped working entirely, so I got to tab around to install and run the correct one. Everything seems to work now!


Framework, would you mind updating the link on this page to default to the 12th gen updates, since that’s what the majority of people are receiving and setting up now? I know it says 11th gen, click here for 12th gen right in the title, but I was too tired and too excited to set up the computer.

1 Like

Has it been changed or is this not clear enough ?

Don’t forget to install the Driver Bundle (11th Gen Intel Core or 12th Gen Intel Core)!

That set of links you referred to, from step 13 in the guide, is totally clear and easy. What I did was click the link in the DIY intro here, which just goes straight to the 11th gen page.

I was really tired, but wanted to get the computer going for a work trip the next day. So, once I got Windows installed, I opened the DIY page, and then just clicked the link in the intro to go get the drivers (instead of scrolling all the way down to the last step) since I knew that was the first thing I should do. Anyhow, I know I could have read more and avoided this, but I was tired and rushing. Just hoping that changing that link in the intro might prevent anyone else from having the same dumb moment.

1 Like

From what I can see, from a link on page Framework Laptop DIY Edition Quick Start Guide - Framework Guides which has the text you quote


Yes, exactly. Once on that page, being tired and rushed, I just looked right at the table and chose the download, rather than reading the top. So I ended up grabbing the wrong drivers. Just figured that link could now be directed the the 12th gen driver page.

1 Like

It is not our purpose in this thread to keep trying to prove @Sami_Hammer wrong. They’re asking for a reasonable clarification to the document that they followed. We all make mistakes. C’mon now. :slight_smile:

1 Like

I had no idea that @Sami_Hammer was wrong I just took time to find the relevant page as it wasn’t specified.

It was never about nor will ever be if a person is right or wrong but questioning someone that indicated they would like attention or help when I don’t see the issue clearly.

Nor do I think it wrong that Framework have a link which may not suit the majority of users (all 12gens) Just not the most efficient for the user.


I could have done a better job lining out the whole situation once I realized what I did, and adding both a link and a screenshot of the part of the page I was talking about.

1 Like