Windows - No Audio Output Device is installed

Hello. I normally run Linux on my Framework (Arch), and I have no issues. However, due to an online exam and lockdown browser (college student), I need to use windows. I was able to install it a few weeks ago on a 250GB expansion card using Rufus and Windows-to-go, and after installing the driver bundle, everything works except sound.

I feel like it worked a few days ago, but I can’t remember for certain. When I hover over the volume button in the taskbar, it says “No Audio Output Device is installed”, and when I click on it, it launches the Windows Get Help app.

I’ve tried reinstalling the driver bundle, as well as extracting the bundle and installing the realtek driver separately. That didn’t change anything.

Under Device Manager, there’s no sound devices at all, but under ‘Other Devices’, there’s “Intel High Definition DSP”. I tried letting windows install a driver, but it couldn’t find one.

Any help would be appreciated, it’s somewhat urgent. My exam is on wednesday, and the lockdown browser requires access to the microphone.

(I should note, this is with the 8-31 driver bundle)

So, I tried uninstalling the Realtek driver from Add/Remove Programs and reinstalling it. While the driver bundle was running, I suddenly got audio back for a few moments (while Intel Smart Sound was being installing), but once it got to “Installing Realtek driver” sound broke again.

Now, both the speaker and the microphone show up as sound devices. I can control the volume. However, there’s no output from the speakers, and nothing from the microphone. Under Device Manager two audio devices now show. “Realtek(R) Audio” and “Intel Smart Sound Technology for USB Audio”.

Is Windows update trying to add/replace the driver itself? I’ve often seen the updates break things so uninstalling the update (or installing if it isn’t present) may help.

Could you try installing the previous non-Beta driver bundle and seeing if the behavior is different? How do I download drivers for my Framework Laptop?

@nrp Sadly no change. I uninstalled the Realtek driver beforehand, to give it a good shot, but the behavior is still the same as with the beta bundle (after reinstalling Realtek). The speaker and mic show up, but the speaker is non-functional, and the microphone is completely dead.

Apps like Audacity throw errors as well, stating that no audio devices were found.

It did the same thing as last time too, where audio worked momentarily during the bundle install, but was broken at the end of the install (and after the reboot).

Update: I ran the realtek setup from the non-beta bundle, which started by uninstalling the existing driver and rebooting. Currently, all audio works, including the mic. It currently shows just as “High definition audio device”, using the Microsoft driver.

Seems like the Realtek driver really doesn’t like my machine for some reason.

1 Like

@darthdomo Hi - I’m having this same issue and have had no luck getting the audio to work. I did a complete wipe of my laptop and reinstalled windows. The audio worked right after the windows reinstall but after updating all of the drivers and restarting, audio is no longer detected. I downloaded the Framework bios and driver bundle but don’t see any way to extract just the realtek driver. How were you able to get just the realtek driver so you could uninstall the existing and reinstall the new one without affecting other drivers?

This issue may have something to do with Microsoft’s half-baked Windows-to-Go, which is no longer supported in Win 10 2004 and above according to Microsoft.

@David_KD See Step 1 below

What seems to happen

TLDR: Some installers refuse to run if they detect Windows-to-Go. Some Windows-to-Go “features” get enabled if you boot your internal drive via usb enclosure/adapter at any point.

Long Story

You do not necessarily have to have enabled Windows-to-Go yourself. If you ever booted an existing standard Windows instance via a USB enclosure (SATA to USB or M.2 to USB etc) to, for example, clone your boot SATA drive of your old laptop, to the framework’s internal SSD (with software that supports live OS cloning), or to troubleshoot any other PC etc., it looks like certain registry values and other bits and pieces get enabled automatically by Windows, and will have to be changed back by hand, otherwise there may be issues with installing some software that checks those values.
Instructions that worked for me to convert it back here, although this doesn’t seem to help with the audio driver but does resolve issues with some other software installs (unfortunately I do not remember what exactly I was trying to install at the time of discovering that my Windows somehow converted to Windows-to-Go)

In my case having Windows-to-Go enabled in the past, seems to have caused the installer to skip some of the Intel Smart Audio drivers.

Solution (at least for me)

Step 1. Use 7-zip to extract the contents of the driver bundle

How to extract
  • Download and install 7-zip
  • Right-click on the “Framework Laptop Driver Bundle” downloaded from here
  • Hover over “7-zip” in the drop-down and extract to a desired location.

Step 2. Use Device Manager to manually install the driver for Intel Smart DSP from the extracted folder (once the driver is installed more “Other devices” will appear, ignore them for now)

How to manually install the driver
  • Right-click on “Start/Windows Logo”
  • Select “Device Manager”
  • Expand “Other Devices”
  • Right-click on “Intel Smart DSP”
  • Select “Update Driver”
  • Select “Browse my computer for drivers”
  • Select “Browse”
  • Navigate to the extracted folder location
  • Select “Intel Smart Sound Technology” folder and click “OK”

Step 3. Reboot

How to Reboot


Step 4. Run the “Framework Laptop Driver Bundle” again to install the drivers for the newly discovered devices.

P.S. You may or may not have to run the Realtek Driver setup after, (Setup.exe in the Realtek folder) Mine installed automatically via “Microsoft Store” of all things, before I even had a chance to restart…WTF?

1 Like

Might be a good idea to link to stand-alone driver packages alongside the bundle installer. May make it easier to troubleshoot driver issues between bundle releases if there are any newer drivers that are not yet in the latest bundle.

May also be a good idea to link to the Intel Smart DSP and Realtek drivers in the knowledge-base article here

1 Like

Hi, I downloaded the latest Beta drivers for Windows 11 from Framework site. Using an unzip program extract the individual drivers. Install the realtek audio driver and restart machine. I tried various other things but then uninstalled the realtek driver and the sound returned.

Anybody know what driver I’m looking for (file name) in the Framework Driver Pack? I have purchased 2x DIY Gen 12 Laptops with one has audio and one has not.