Framework 13 12th gen windows install issue

Hi all, I got my framework 13 earlier this year and installed Fedora 37 on it when I got it and worked fine but I decided to go back windows but could not get windows 10 or 11 to install. It said “a media driver your computer needs is missing. This could be a DVD, USB or hard disk driver.”

I have tried to disable secure boot, disabling TPM but no luck. The bios and windows can detect it (using diskpart) so it isn’t a hardware issue.

Has anyone else experienced this and if so, how did you fix it?

1 Like

So you have created a Windows Bootstick and you land in the installation menu or were does it get stuck?

Like make sure you have created a working boot stick on another device.

I hope you are able to get the issue sorted.

Precisely, as Ian is asking if you made a Windows install boot drive then the necessary drivers to run setup and install the necessary files are already present. Once Windows is installed, as per the Framework instructions, you will need to install the Framework Windows Driver pack. This will ensure all devices work as they should and you will be good to go at that point.

I assumed we are talking about Windows 10 here:
Windows 10 Installation on the Framework Laptop DIY Edition - Framework Guides

However, they have a Windows 11 installation guide as well.

1 Like

I have followed that installation guide and once I select the language and keyboard layout and click install I get the error.

I downloaded the iso from Microsoft, created a bootable USB using the Fedora image writer (I don’t have any windows installations to use the windows tool Microsoft provided)

When you say the Windows install boot drive are you talking about the USB media or creating one on the disk so you can boot from it?

Do you have access to another PC to either check your boot stick or to make a new one with rufus or the Microsoft Media cration tool?

No, I don’t. All my other computers have Linux, not sure how well it would run under wine.

Is there much difference to using the iso from Microsoft and using the media creation tool? I have never had these kind of issues installing windows 10 before from the downloaded iso.

Have you copied the WiFi driver to the root of an usb? You have to plug it in before you confirm the language as described in this article.

I cannot copy files to USB disk since it’s read only and the issue was not the wifi, it was the disk and the windows installer not detecting it.

And even if I could, I don’t have the drivers available since all I have the the exe for driver install pack which I cannot run because I don’t have a PC with windows.

1 Like

Do you have discord?

How did you manage to solve this? I’m having the same issues with my new framework 13 Intel 13th gen DIY.

Specifically, what issue are you experiencing installing Win 11 on your FW13 13th gen?

Did you build the installer using the media creation tool at this page?

Did you see this support doc regarding the wifi driver?

Hi @Scott_H, thanks for your quick response.

I could not use the media creation tool. I do not have a product key because we get Windows through the university, but only as an iso file, and it is activated when it finally connects to the university network. With an ISO file, I was limited to using Rufus or Ventoy, both of which failed for me with a “media driver missing” issue. I had already set the Wifi to fallback mode, so that wasn’t the problem.

After trying for a few hours with several different USB sticks, I figured there was some deeper issue. So I tried loading the Ubuntu iso with Ventoy, and that worked fine (I didn’t install it but at least I was able to try it). So as a final resort, I tried installing Windows 10 (iso) instead with Ventoy, and this almost worked. I figured that the issue was that it didn’t like my newly bought NVMe SSD. I had to troubleshoot with the command prompt and reformat it to GPT. Then I was able to install Windows 10 perfectly fine. However, I was still unable to install Windows 11 (and I have no idea why).

Eventually, I gave up and ended up launching the windows 11 setup.exe from within my installed Windows 10. All in all, pretty frustrating (and I really wish I could just use this as my Linux machine).

What’s preventing this from happening? Maybe someone on the forum can help?

Oh no, nothing technical is preventing me from that. I just need to use PowerPoint, Word, Photoshop, Illustrator, etc. for the next few months. I know alternatives exist, but I’m in a time crunch at the moment. And for most of my linux needs, wsl2 works incredibly well with VScode. Around summer next year, I’ll likely switch to Linux.