11th Gen Intel Core BIOS 3.19 release

11th Gen Intel Core BIOS 3.19 is released. But first, some background.

PLEASE USE THIS LINK: Framework Laptop BIOS and Driver Releases (11th Gen Intel® Core™) FOR CURRENT INSTALL SUPPORT.

  1. We’ve been delayed on BIOS updates due to issues we found in the update process, especially on Linux, and due to staffing constraints at our ODM partner. We’re working with them to enable more consistent staffing for sustaining work on launched programs. Note that there is a matching firmware update in progress for 12th Gen Intel Core, and the release schedule has been slow due to these issues.

  2. On general philosophy is to have complete firmware out of the box when we launch a product. In general, we don’t plan to have new features that we add post-launch. Instead, post-launch updates are for issues that are found in the field or for security updates that we receive from our upstream firmware suppliers, which include the silicon vendor like Intel or AMD along with our BIOS supplier, Insyde.

  3. Our target timeline to go from Beta launch in the community to final release is two weeks. We monitor the community thread to find if there are regressions in the release that would prevent promotion to final. Note that while both we and our ODM partner do testing on the release prior to the Beta, there is still the potential for issues we didn’t catch, so we recommend only using Beta firmware if you are comfortable with that risk.

You can check your current BIOS version following the steps here to determine if you are on the latest release.




Instructions for Windows Installer:

  1. Run the .exe.
  2. If prompted to trust the Framework driver signature, click agree.
  3. Click yes to reboot.
  4. Wait for all 3 firmware progress bars to complete as the installer will install 3 different firmware updates and will then reboot into Windows.

Linux/Other/UEFI Shell update

We’re releasing the Windows updater first. We do intend to have an UEFI Shell based updater available for those on Linux or other OS’s.


There will not be an LVFS update for this specific release because it has an Intel CSME update, which can’t be delivered through LVFS. Use the UEFI Shell update method instead for this release.


  1. Update Intel CSME package to Corporate.
  2. Move to shared EC branch with 11th, 12th, 13th gen.


  1. Insyde security patch to fix CVE-2017-5715.
  2. Fix SMBIOS type2 location on chassis string6.
  3. Add ACPI mutex in UCSI mailbox with EC to avoid race condition with other ec communication.
  4. Fixed LED blink green when EC power on.
  5. Fixed cannot power on EC chip.
  6. Reduce charger input current limit to 0 when switching between type-c port in a multiple adapter scenario.

Component Versions

This BIOS update is a bundle of updates to multiple embedded components in the system.

Not all of them use the same version number.

BIOS 3.19 Updated
EC f6d6b92 Updated
PD Same as previous version
Intel CSME Updated

Known Issues


IhisiServicesSmm BRLY-SA-2023023/CVE-2023-22613
BdsDxe BRLY-2022-021/CVE-2022-35897
SetupUtility BRLY-2022-020/CVE-2022-35407
PiSmmCpuDxeSmm BRLY-2022-028-RsbStuffing
IhisiServicesSmm BRLY-SA-2023021/CVE-2023-22615

Thanks for the update @Matt_Hartley! I’m just wondering if there are plans to fix the 6GHz WiFi issues caused by the 11th gen BIOS with this update. I know you already said that there are no plans to fix it in the linked thread, but since you guys are doing a BIOS release anyway, is it possible to do anything about this? I just updated my 11th gen to the beta update and can confirm that the issue still persists. I would hate to have to throw away a perfectly good AX210 just to take advantage of my WiFi 6E APs.


Heya! Thanks for the update, much appreciated from a 11th gen owner :slight_smile:
Was wondering if there were release notes anywhere? I may just be missing some obvious location.

Believe this falls into the feature vs stability/security update camp. So if it’s not present, this is likely why.

1 Like

Hey, where’s the changelog for this update?

Edit: I see it was just added :sweat_smile:

1 Like

That was on me, the entire message didn’t carry over - corrected.


PSA - if you are running linux and install the update via windows on an expansion card (my case) or external drive, don’t be stupid like me, go ahead and physically remove your internal nvme so that its efi / grub setup doesn’t get messed with.

After I blew things up, using ventoy to boot to a manjaro live iso allowed me to access refind on my internal drive, and from there get back into my linux installation. I then reinstalled refind and ran update-grub, and all was well.

TL;DR - don’t be me,

Edit to add - other than my mistake, the update went smoothly and the machine has been operating normally.

Have a good evening, all.


Got it installed, no issues so far! Happy to see most of the device security issues resolved.

1 Like

I also had time to install (Using Windows) and so far no issues. Have not had any real time to test yet beyond posting this message LOL. But if I get a lot of use this weekend I will post anything I notice, if any (never noticed any issues with 3.17 and I use daily).

1 Like

Initial install went fine on an 1135g7


Don’t feel to comfortable, the known issue section states vulnerabilities.

Software security is often a moving target - as I understand it most or all those vulnerabilities are also in the former available BIOS, whereas this version includes updates to the CSME, IME, and Insyde software that fix a laundry list of CVEs for those (relative) black boxes. That’s why I said “most” :slight_smile:


This is correct.


Quick question,
Sorry if this is a repeat, but I does this beta support “not being in a laptop format”? I noticed when I ran 3.17 I have to take it out of the framework case (Cooler Master) and then install it back into the laptop format as it wouldn’t proceed without a battery present. Is this beta bypassing this check and allows an update?

1 Like

Speaking of battery, @Matt_Hartley does this update have compatibility with the 61wh battery?


I’m confused. The 11th gen laptops were sold and advertised with wifi 6e support. This isn’t a request for a new feature, but a request for a bug fix. Telling people to buy a new mainboard when their current one is working just fine (minus a bug fix) doesn’t seem to be in keeping with the company’s mission.



With the additional staffing we have in place for sustaining firmware updates, we’ll be including investigating functionality regressions.


I’ve installed my 61wh on bios 3.19, but tlp-stat is reporting that its design charge is 3915mAh. Any insight? edit: I’m an idiot, did the calculations and it’s 61Wh.

Full tlp battery info (earlier up in tlp it says it’s bios 3.19, and the update completed without issue a few days ago):

+++ Battery Status: BAT1
/sys/class/power_supply/BAT1/manufacturer                   = NVT
/sys/class/power_supply/BAT1/model_name                     = FRANGWA
/sys/class/power_supply/BAT1/cycle_count                    =      1
/sys/class/power_supply/BAT1/charge_full_design             =   3915 [mAh]
/sys/class/power_supply/BAT1/charge_full                    =   3901 [mAh]
/sys/class/power_supply/BAT1/charge_now                     =   1019 [mAh]
/sys/class/power_supply/BAT1/current_now                    =   3768 [mA]
/sys/class/power_supply/BAT1/status                         = Charging

/sys/class/power_supply/BAT1/charge_control_start_threshold = (not available) 
/sys/class/power_supply/BAT1/charge_control_end_threshold   = (not available) 

Charge                                                      =   26.1 [%]
Capacity                                                    =   99.6 [%]

Matt stated that it was a “feature vs stability/security” he never stated anything about this being a new feature, but that it is a feature that is not a part of the security or stability of the device. As Nirav also mentioned in his reply to you, now that there is additional staffing in place, fixing more things other than security and stability can be worked on in future BIOS updates.

While Matt did seem to indicate that you would need to buy a new mainboard to get this functionality in the other thread, it also seems like the current issue is just that the computer can’t use the 6GHz bands on wifi 6E, but that it can use all the other bands fine. Trashing an entire mainboard just because it can’t use 6GHz bands also isn’t keeping with the company’s mission.

1 Like