13th gen BIOS

Where can I find an installer for the current version of the 13th gen bios? I need to reinstall the bios, in order to fix the problem(I think anyway), and
doing a bios reset (pushing the chassis intrusion button 10 times, then the mainboard power button) only fixes 2 out of 4 problems temporarily

in addition to what is bellow, right click often just stops working so i have to restart my computer to fix that often.

also i talked with costumer service, and they told me to do a bios reset (pushing the chassis intrusion button 10 times, then the mainboard power button) , and they also mentioned that this is a bug. My framework laptop was perfectly fine for the few months before this, so I suspect if i reinstall it from sctrach, and maybe even use a different ssd, it will work again.

Pervis message about what is happing that I wrote a few months ago:

title: High bios time(more than 90 seconds), USB doesn’t work, Bluetooth doesn’t work, and fingerprint reader doesn’t work

I tried to connect my Bluetooth headphones. my Bluetooth icon, was not there, so I ran windows diagnostics, and I said that my laptop has no Bluetooth adapter. (Wifi still works btw) So i tried reinstalling framework drivers. There driver install fixed nothing, and gave me a pop out that said something among the lines of no fingerprint reader detected. later I plugged in a USB drive, and it didn’t show up. I plugged a few other items into all the USB ports, and none of them showed up. I looked into device manger, and all of them showed up as “Unknown USB Device (Port Reset Failed)” It also said;
“Windows has stopped this device because it has reported problems. (Code 43) A USB port reset request failed.”
on the general page of properties.

This would not solve anything. The code of the BIOS does not corrupt by itself. If it does there are extreme hardware problems with the device anyway that will not be solved by simply overwriting the code.

Outside of an ongoing BIOS update, the only thing of the BIOS that could corrupt is the settings. And those will be reset by a BIOS reset.

1 Like

The issue seems to have fixed itself - please make sure to read the “Update” at the bottom of this comment.

I’m also on a Framework 13, 13th gen Intel, and seem to have many of the same symptoms.

I’ll probably raise a support request, but I seem to have exactly this issue:

  • The laptop was working fine for a couple weeks, although I hadn’t used it much
  • When I went to use it today, the battery was very low (6%?). I’m not sure if that’s what caused the issue (if I left the laptop on by accident) or if the issue meant the laptop did not shut down properly. But I’m not sure if the problem happened immediately after the battery being low, or some time after.
  • Booting (bios/before windows) takes a long time, every time, similar to when you boot the laptop the first time and it calibrates. It blinks the boot status indicator LEDs (can post later) and takes a long time to reach the framework logo, after which it boots normally.
  • I think at some point the USB port(s) were working, as I had plugged in a USB 3 Hub with ethernet port and was using the ethernet connection. However, now the USB ports don’t work (I have 1 USB C for power and 3 USB A, and they all don’t work, or sometimes windows would show “this device is not recognized”)
  • The fingerprint sensor, which previously worked, doesn’t work (windows says it can’t find a fingerprint sensor)
  • Additionally, the computer can’t shutdown normally - the screen turns off and the fans blow quite loudly, and the laptop gets warm. I need to hold the power button for some time and release it to power off the system.
  • I also experienced one freeze while using windows (not a bluescreen, just didn’t respond), needed to forcibly power down by holding the power button down.

I tried (none of the below fixed the issue):

  • Updating to latest Framework 13 13th gen driver (03/28/23)
  • Using only one of the two ram sticks, in case one was broken
  • Putting in a blank SSD (to see if the slow boot/can’t shutdown issue would go away)
  • Testing with power plugged in/not plugged in
  • Disabling fast startup in bios
  • Using the bios setting which disconnects the battery, in an attempt to reset any bad state
  • Doing the above bios reset instructions by pressing the intrusion lever(SW3?) 10+ times, then powering on via the mainboard switch (SW1). However not sure if this actually reset the bios.
  • Windows “Fix problems using Windows Update” (re-install windows but keep apps, files and settings)
  • Reset Windows (do not keep apps, keep files)
  • Go back to previous build of windows
  • “Load Optimal Defaults” in bios (even in bios, the system doesn’t appear to be able to restart properly, so maybe it’s unrelated to Windows/the OS)

Framework USB Port Reset Failed

Update: I left the laptop overnight, and when I re-tested this morning everything works (the laptop boots normally, shuts down normally, and the USB ports work). I should note that was quite cold this morning, and last night I didn’t leave the laptop long enough to fully cool down, if that somehow affects it. Or maybe something took a long time to discharge/lose it’s state (the battery was connected to the laptop overnight, but not power)

I’ll report in if I see this issue again.

I’m experiencing all the same issues you are and am wondering what you did to fix the issues. When you left the laptop overnight, did you just shutdown and let the fans ramp up over night?

Firstly, see the “main” thread about this issue: Extremely slow startup, loss of Bluetooth, external storage not recognized - #18 by drojf

In short, the issue happened again, so I contacted support, who eventually agreed to replace the motherboard. I never figured out a series of steps which would ‘fix’ the issue reliably.

If you just need to use your computer in the mean time (without using the USB ports), there is a workaround that Nicholas Shepard posted in that thread.

1 - First Boot into bios.

  • I found the easiest way to get into bios was to use Windows 11’s Advanced Startup Options (type in start menu) → “Advanced Startup” ->restart now .
  • Then you may need to forcibly restart the computer if it won’t power off itself
  • Then when the recovery menu appears some time later, go Troubleshoot->Advanced Options → UEFI Firmware Settings
  • Again forcibly restart the computer to get into bios

2- When the bios appears, go Security → I/O Interface (scroll all the way down) → External I/O Ports and disable external I/O Ports.

We’ve got a unit doing the EXACT same thing with USB issues and very slow boot up/post. All USB ports do not detect external devices amd have the same “unable to reset” error in device manager but they do allow PD power supply charge. Internal USB also seems to be dead as the camera is not found, fingerprint not found, etc. We’ve disconnected battery and cmos battery for over a day, etc.

I have removed all EMI shields from the USB C ports to check for short, nothing looks damaged. What has support come up with for you?

3.03 for Intel 13th Gen (latest official): https://downloads.frame.work/bios/Framework_Laptop_13th_Gen_Intel_Core_BIOS__3.03.msi

3.04 for Intel 13th Gen (latest non-official):

What has support come up with for you?

Motherboard replacement :sweat_smile: