[SOLVED] Bricked after updating bios and drivers

13th gen intel board with windows 11 installed. I downloaded and ran the Bios and Drivers from BIOS and Drivers Downloads and at the end it said it needed to reboot to finish. Rebooted into a bluescreen and I tried to do the autofix which didn’t work so I planned on just re-installing windows. Before I could the screen went blank and now the power button does nothing. I can hold it for a few seconds and get a green blink out of the leds on side, but nothing else happens. I redid the connection to the keyboard and unplugged the battery for a minute, but nothing has changed. Anything else I can do to bring this back?

Try only using one stick of ram and see if you can at least get into the BIOS. You may have a bad stick of RAM or a fried SSD as 13th gen doesn’t have a BIOS update, only drivers.

Thanks for the ideas, but no luck. I tested each stick in the 0 slot and nothing changed. I also put the ssd in my desktop to verify that it was still alive. I am confused, because it doesn’t do anything when I press the power button and if I hold it a few seconds the led on the right side will blink green once. I can also confirm with the keyboard off but still connected the leds blink red when I press the power button. I just can’t figure out how to get it to just post the bios.

Pretty odd, I wonder if it’s something to do with the display or iGPU. But at this point, I think it’s best to open a ticket with Support.

Well I have to admit I feel pretty stupid, but luckily I had my sons friend look at it and we realized that the powersupply that came with the laptop isn’t working at all. The whole problem was that the battery was completely dead. Now to see about getting a replacement power supply, at least it is one of the cheaper things to have broken.


That’s a pretty good resolution. At least you won’t be without a laptop while you wait for a replacement. Is the cable frayed on the power supply? A common issue is that the USB C cables can get damaged.

agreed, I feel very lucky. All the cables check out and work when I plug into other things, just the power brick itself seems dead.

Support might take a little longer to respond as they’re swamped with AMD order tickets but as long as you get an automated email from support request page, you’re in their system.

1 Like