Alert sound when charging on AMD

Hello! I’ve just assembled a new AMD 13". It works fine, except that when I try to charge it through the USB-C port, I get this alert-beeping sound though the speakers every few seconds, and the port light is fishing amber. Does anyone know what this means?

It seems to happen both if the laptop is booted or shut off. Same result with two different chargers.


Have you updated it to the 3.03 bios and installed the new driver pack?

The laptop came with 3.03. I don’t have Windows on it (only Linux), so I’m not sure about the driver pack. But the problem happened also when the laptop was turned off, so I’d assume that drivers don’t matter.

In any case, after letting it sit for a night, this morning I’ve taken the USB extension cards out and put them back in, and after that the laptop seemed to charge fine ¯_(ツ)_/¯.

I’ve definitely noticed some funky behaviour with charging and there’s a thread discussing it.

Actually, I spoke too soon. This is still happening to me. After I plug in the charger, sometimes everything seems to be fine, sometimes the LED blinks amber for about 20s during which time Linux claims the laptop is not charging, and after that time it starts charging, and sometimes the LED flashes and I hear the alarm beep in the speaker, and then after a few seconds the sound and blinking stops and the charging starts.

@TheTRUEAsian can you kindly point me to the other thread you mentioned?

Thank you!

In my case, it seems to have all been charger-related. I had tried 2 different charger, but now with a 3rd charger, things appear fine. Sorry for the noise.

1 Like

Out of curiosity, what were the two types of chargers that caused this behavior?

One of them was a charger from a Google PixelBook laptop (not sure about the power), the other from a MacBook Air (35W).