Framework 13 AMD - Speaker buzzing noise when charging

Hi everyone,
I have noticed that when my Framework 13 AMD laptop is charging, every time I open an application which uses sound (etc. Discord, Youtube) my speakers start to buzz.
The speakers are silent when I first enter Youtube for example, but as soon as I start a video, muted or not, the speakers start to produce a crackling noise.
As for Discord, as soon as Discord starts the speakers start buzzing as well.
I’m assuming that as soon as an application starts which uses speakers they start buzzing, but only when charging.
If I disconnect the charger while the video is playing or Discord is opened, the buzzing sound stops.
Hope I explained it clearly enough.


  • BIOS Version: 3.0.3
  • OS: Arch Linux
  • Kernel: 6.1.61-1-lts
  • DIY version AMD Ryzen 5 7640U
  • I have TLP installed
1 Like

Same thing happened to a friend of mine. I wonder what’s causing the issue… Hope you get resolved soon :slight_smile:

Are you using the charger that sells?

Yes, I’m using the Framework charger with EU adapter. I’ll edit the description for further clarification, thank you!

Does the buzzing sound change if you are touching the metal part of the laptop while standing on the ground? Either way, it is most likely related to a ground-loop issue. Framework adapter seems to be grounded as it has 3 prongs, but perhaps the AC outlet you are using doesn’t have Earth/ground connection or you are using some adapter with the charger that is without the 3rd ground connection?

The buzzing sound does not change if I touch the metal part of the laptop.
The EU adapter that came with the Framework charger has ground wiring and the outlet has ground so I do not thing that that is the problem.
I tried with a different charger (off-brand) which has no ground wiring on the power chord and the same thing happens.

In conclusion: the buzzing is persistent whether or not its connected to the ground (charger-wise). Maybe the wiring inside the laptop has places where electric charge can jump or move (I’m not an electrician so excuse my ignorance).

Yeah I had asked because I was thinking it wasn’t grounded properly as a non grounded power brick usually causes these issues. Do you have a multimeter to test to see if there is continuity between the ground pin on your cable? Throwing stuff at the wall and seeing what sticks here.

I will try to get a multimeter from a friend or something and try that out, but I tried multiple outlets so I doubt that is the problem :confused:

In the meantime I will try maybe to linux kernel instead of lts and try to boot a live image of another OS to test if it is an Arch issue or hardware. If so, I will contact Framework support for further assistance.

Thank you all for your suggestions, will keep the post updated with further progress!

Hello once again,
Good news is I narrowed down the problem and it’s not a hardware issue but rather an Arch issue (probably due to power saving settings).
I have booted a Ubuntu live image from a USB and tried to play audio while the charger is plugged in and the buzzing stopped.
I tried disabling TLP and tried PowerDevil and the buzzing still continues.
I’ll continue searching for the problem since now atleast I know it’s an OS issue and not a hardware one, thank god :smiley:

1 Like

The issue is still persistant. Turns out when I installed Ubuntu the speakers are still making a static noise when playing sound on charger. I even tried installing Windows to test it as well and same thing happens.
I will raise my problem to Framework Support and will update further once they reach out to me.
Thank you all for your suggestions!