AMD board solely in the coolermaster case?

Right, there is a knowledgebase article that states the following:

When I search for any compatible batteries, I only find non-rechargeable options. I’ll open a ticket with support to see if they have any recommended batteries or have some sort of timeline for it getting added to the marketplace.


I mean you could probably take a cable like this and solder on any rechargeable 3V Lithium manganese dioxide battery (ideally with holder) that fits into the case.

1 Like

Okay, so heres what I got for you on the “solely coolermaster case” situation since I got it figured out (or as much as I can).

a) Use a smaller, slower RAM set for your initial config (maybe borrow an 8GB DDR5-4800 SODIMM and only use it to populate DIMM0?)

b) Do not install an NVMe drive onto it yet (especially if whatever you plan to install doesn’t have the Secureboot shim prebaked, I am talking about VMWare ESXi, Proxmox before version 8, Opnsense (or FreeBSD), Debian 11, Ubuntu 20 LTS or below). Put the Ryzen board with the smaller slow RAM onto the Coolermaster case and close it up, but do not put the screws back on. Just make sure that the chassis sensor is engaged.

c) Use a 100w USB-PD power brick (if possible) and plug it onto the USB-C port closest to the bottom/front/whatever, left or right is fine. USB-A and HDMI at where-ever you prefer.

d) Once you power it up, it might do the red/blue blink storm (it’s the left side/right side status LEDs doing a police car impersonation non-stop and doesn’t respond to a power button press). Just let it run for a bit until it finishes up - your left LED will go solid white and the board will turn on. The more RAM it has the longer the blink storm. After this stage do not disconnect the power until the entire ordeal is over. The HDMI might fire up after a few minutes (when the blink storm is done) and you should be greeted with a message saying that the machine can’t find a boot device. That’s fine. Hit okay, and it should take you into an Insyde H2O screen.

e) You should see several options. One is to administer secureboot and one is to setup. Keep in mind that on the 11th/12 th Gen Tiger/Alder Lake boards Secureboot is inside the BIOS setup screen. On the 13th Gen Raptor Lake and Ryzen Phoenix, it’s that “Administer Secureboot” screen that you’ll need. Go into it, turn off Secureboot (or its enforcement) and then hit F10 to save and exit. Your board will restart and should come back up in 10 seconds. Note that this entire step is not needed if you are installing anything with the Secureboot shim pre-baked into the install media (i.e. rufus with an ISO for Windows 10/11, Debian 12, recent Ubuntu/Fedora). Keep in mind that if Secureboot is enabled, and you tried to boot the system using a non-secureboot shimmed filesystem, the BIOS will not allow you to disable Secureboot. When that happens, remove the offending device(s), and restart. If you have to yank the power, you might have to endure the red/blue blink storm until this is up and running again.

f) At this stage, same error should pop up - no boot device. This time go to setup, turn on Standalone mode. Hit F10 to save and exit. Restart, see if the settings are saved correctly, then unplug power, open up the coolermaster case and install the NVMe drive. Leave the small RAM unit in. Get whatever install media you have, plug it in, hit F12 repeatedly for the boot menu once the red/blue storm is done, and do the install.

g) Once you verify that the install is successful and the board is working, then unplug and swap the final RAM count in. Reboot/power cycle, F2 to BIOS, Turn Secureboot back on again at your own discretion. Some better behaved recent OS installers will install the Secureboot shim in as a courtesy…some won’t. That’s up to you. At this stage the board should behave as per expectations.


Reminds me of this scene:

1 Like

Champion! That relieves so much anxiety!

I’m guessing just before this, there is the additional step of upgrading the bios by the usb method: AMD Ryzen 7040 Series BIOS 3.03 and Driver Bundle Release

Eh, I don’t think anything in the BIOS update will fix this issue per-se, but you are welcome to give it a try.

Now livestreaming my initial unboxing and setup:

Unfortunately the video did not save! What a bummer. See my later post for a new video recapping the issues.

1 Like

You can’t disable secureboot? Do you not have the option in the F2 menu?

1 Like

Slightly painful to watch…board orientation, refer to the guide:

@Second_Coming board orientation was correct, until recently I had the camera inverted/flipped, so I guess that confused you. I’ve added a shortcut in the future for swapping the mirroring/inversion of the camera.

Once I’m done with the boot sequence, I’ll upload photos.

Unfortunately the original 4h30m stream didn’t save, which I was counting on. It showed all the unboxing and the trial and error.

Here is a new stream where I recap the issues:

The Case

This is the orientation, which is the correct and only possible orientation:

See framework’s own photo:

I was unable to get the case’s lid to close with the framework board in, the top right corner was sticking out. The power button was pressing against the board. Upon inspection, the top right corner of the mainboard which wraps entirely around the case pin, had a black nodule that was pressing against the side of the case and could not go further down. Figuring that this was the only issue and an easy fix, I scraped away some of the plastic on this corner to make room for the board. After a few scrapes I realised I should take some pictures, along with the stream, so here is the first picture showing that the board would not go down due to the nodule contacting the case (photo from original stream):

Eventually I scraped enough that the nodule was no longer making contact (photo from original stream):

However, then the corners on the left side of the case also contacted the mainboard. So I had to scrape them away a bit too, only a tiny bit though.

That then allowed me for the first time to get the mainboard down enough to where the usb ports were somewhat visible through the case (photo from original stream):

Now after dealing with the plastic edges of the case, the final challenge presented itself. The pins of the case are too tight — I noticed this as there were marks on the pins from where it was rubbing tightly. I tried to sand the pins down for a few minutes but that did not help, it is still too tight for the lid to fit and for the ports to align.

Here is all the progress I could make, of which the photos were taken in the restream video:

If I were then to press down on the top right corner pin where it would get stuck, this would help with the right side but it would pop out the left side:

If I were to go right side first, and then left side, this is the best it can do:

Finally, the case lid still cannot close properly (before all the modifications it stuck out about 5mm, now it is down to about 1-2mm), this is because the power button presses against the board and the board cannot sit low enough:

The Mainboard

I could not get the mainboard to boot at all, not even to bios, nothing came alive. It just did the red/blue lights forever. I tried a single 16gb ram from framework in channel 0, then the other in channel 0. I tried swapping different ports for the charger, keyboard, and hdmi. I tried a 96W apple charger, a 87W apple charger, a 65W heymix charger, and various 100W charging cables including a thunderbolt 3 cable. It just stays at a baseline 0.4W forever (20V 0.02A), adding 0.2W depending on the USB devices attached. I tried an apple usb-c to -usb-a adapter for the keyboard, and a ugreen adapter. I tried a usb-c to usb-b keyboard. I tried a pluggable usb-c to hdmi adapter. I tried a usb-c flash drive with the bios update.

@wang perhaps you got lucky because as I recall, you had the infinite red/blue lights but then moved it to a framework laptop chassis and were able to finally get something. I think that could have been the magic that made everything else in your instructions work.

The only thing I can think of is the 96W charger is not suitable (along with the 87W and 65W)… perhaps it needs to be a over 100W charger. Earlier thread about wattage. I will wait to see what Framework says, and perhaps I’ll buy a 140W apple charger.


I will email Framework and find out what can be done.

Yes, I understood that it was flipped in the original stream because texts were flipped. The orientation comment was made because you “did try” different orientations along the way.

Also, “painful” was in relation to the end-user experience. The notch and scraping / cutting / scratching… too much work. Wish the case / fit was more polished.


Support responded today:

At present we do not have retail RTC cell that we can recommend that meets the specifications we have outlined in our Knowledgebase but are currently working with our suppliers to make one available on our Marketplace in the near future.

At present the Mainboard will lose system clock when AC power is disconnected from the Mainboard when in standalone mode, but is not a requirement for use in Standalone mode besides this, and is not a requirement for the AMD 7040 series when connected to a Battery, so depending on your exact use case, you may find the impact of no RTC cell to be minimal.

We will be sure to announce availability of the Molex style RTC cell in our community when it becomes available to order.


Framework responded with the following regarding getting the mainboard to boot:

Can you please try the following steps to fix the issue:

  1. Remove all the expansion cards.
  2. Remove the top cover of your Coolermaster case.
  3. Plug the power adapter directly from any of the expansion slots.
  4. Press the chassis open switch in the center of the main board 10 times, you must press it slowly, so press for 2 seconds. Release, and wait for the red blink on the motherboard LEDs. Press, etc.
  5. Put everything back with the external display also plugged in before powering on.
  6. Turn on the standalone CPU and wait for at least 15-20 minutes to finish the memory training and hardware detection.
  7. Wait till it boots up to your Operating system or your BIOS when there is no OS currently installed.

Framework also responded with the following regarding the lack of an RTC battery:

Please note that we designed the AMD 7040 series with the RTC battery optional which is the reason why we’re shipping without it. This reduces environmental impact but also lets us comply with new regulations around child safety for coin cell batteries. The impact of this is that your system clock will reset if you unplug the main battery, but your OS will pull the latest date and time when it next connects to a network time server. For standalone Mainboard use without a main battery, you’ll be able to pick up an RTC battery in the Framework Marketplace shortly. 13th Gen uses a bare ML1220 coin cell, while the 7040 Series uses one on a two-pin connector.

Please perform the steps below and see it if helps.

  1. Plug in the system to AC.
  2. Remove the Input Cover.
  3. Press the chassis open switch in the center of the Mainboard 10 times, you must press it slowly, so press for 2 seconds. Release, wait for the red blink on the Mainboard LEDs. repeat.
  4. Press the power button to boot the system
  5. BIOS settings will be reset to defaults.

Perhaps that will help others.

For myself, I’ve decided to return and refund the items and will pursue something else.


From Mainboard Replacement Guide, Step 10

@Any wandering Framework staff, did a change slip in to the board edges? And it sounds like hole size or alignment too?

Regarding the AMD RTC Battery, seems the Raspberry Pi 5 one could be suitable???

ML2020 Manganese Rechargeable Lithium Battery for powering Raspberry Pi 5’s real-time clock. Supplied with a pre-fitted two-pin JST plug to connect to Raspberry Pi 5’s dedicated RTC battery connector, and an adhesive mounting pad.

1 Like

going through the same issues. waited 3 months and the board won’t even boot. i am trying the framework instructions as i write this but based on testing last night the red and blue lights will continue to run hor over an hour with only a 8GB ram card installed. From wang’s post i am hoping to see a white led but seems like it will never come. I have a ticket into framework but realize they may send the smae steps which do not seem to do anything. if anyone has ideas on how to get past the “police dance” please post anythign else i can try

What make/model/speed ram are you trying to use. No-one has reported success with 5200MHz RAM.

Mainboard (AMD Ryzen™ 7040 Series) - Ryzen™ 5 7640U

DDR5-5600 - 16GB (2 x 8GB) from framework.

the ryxen5 board, ram, and wifi card came as a kit. i have not yet installed the wifi card as i am hardwiring for now. I only have o1of the 2 cards installed right now into slot 0.

as a note i did manage to get it to boot to disable the secureboot per wang’s insturction however I never saw a white light or anything indicating the ram check finished. my screen just came up. I am now attempting to get it to boot again so that i can set stand alone mode but have not been able to get it to boot again.

latest update. managed to get the framework mainboard to boot again. this was in the cooler master case with 8GB ram (5600) and my 1 TB samsung 990 pro ssd. this was done with items in the following ports (case standing up with included rubber stand) 100W power through no expansion card lower right, HDMI display upper left though expansion card, usb-c to usb-a with keyboard and mouse dongle upper right. with this config I followed wang’s instuctions for setting stand alone mode to on. note that at this point i still have not seen any white led.

after saving and restarting, the led is now a solid blue and green on the right side of the computer (about half way up the ram card). I did notice the blue/green light changes to the left side if i provide power from the left side. can anyone confirm the light is just letting me know where power is coming from?

I am able to load live versions of ubuntu or mint without issue when I can power the computer on. i say this because pressing the power button does not consistently start the computer. I am not sure what normal operation “should” be but if it is like every other computer i have used in the last 25 years power on should require a short press only where as a long press would be used only for a forced shutdown. if anyone know an easier way for me to startup the computer or how the powerbutton in the coolermaster case normally operates please let me know.

I have not installed any operating system yet as i want to load windows 10 fist then make a mint partition (and i wont be able to load windows until wednesday).

until then i am trying to just run live operating systems and have noticed i am only able to get video out HDMI (as opposed to usbc) and no audio out of any source. does anyone know if this is a driver issue that cant really be solved until i have a full operating system loaded and can download drivers? additionally does anyone know which how to obtain drivers for mint (i now framework has a windows driver download)?

@balupton Not sure if the RPi 5 RTC battery connector would fit. The battery itself is fine but it’s a two-pin JST plug​ which seems to be different to the Molex 51021-86022 required. I’m trying to find an RTC battery myself but I’ve not been able to find anything.

Ryzen™** 7040 Series:** Rechargeable 3V Lithium manganese dioxide battery with a Molex 51021-86022 compatible 2-pin connector.