Anyone else having issues with WiFi range?

I’ve tried a different WiFi module from another laptop and replaced the antenna kit and the wifi range is still bad. Where the other devices in my house get 50 mbps, the frame work gets under 20. I’ve contacted support and they’re letting me return it for a full refund but is there anything else I can try before I do that though? Anyone else with the same issue or troubleshooting advice? There’s a couple other posts here from people that seem to have poor wifi range but the threads are just dead ends. Thanks.

Biggest question I guess if both antanna connectors are connected properly and that you haven’t damaged them during assembly.

They’re quite tricky to connect.

They’re not damaged. There’s an audible click when connecting both wires and they don’t fall off easily during the wifi module installation. Also, I tried using the wifi module from my old laptop in the framework, then moved it back to the old laptop and the speeds are the same. The old laptop gets good range / download speed and the framework doesn’t. I’ve also replaced the entire wifi kit (this includes the white and black connectors) and there’s no difference.

Can you put any other wireless card in to rule out the AX210/201?

Yes. I’ve tried a qualcomm atheros from my old laptop with the same range results.

Are you able to try a different router? I know that it shouldn’t matter, but might be worth the experiment. Mine strongly prefers a router upstairs rather than an access point that is 10 feet away. It’s connected to the router at 720mbps, a speed test just pulled 316mbps. So the good news is that it doesn’t seem to be something specific to the overall design, but that means that the bad news is that it appears to be something specific to your setup, whether it is the machine or the network. Hopefully you are able to get this resolved, I am sure that it is frustrating. Good luck!

I have similar issues. My old laptop and phone perform just fine for the access point I’m using but the framework’s connection is so weak that it keeps dropping completely.

Have you tried turn the transmit power up or down?

I’ve tried different routers in several different areas and the framework consistently gets a weaker signal and slower download speed than other devices. Regarding changing the transmit power - I didn’t know you could do that, however, that’s not really a solution to the problem. While it might make the wifi better in my own home, it won’t anywhere else.

Are you on the latest BIOS and drivers?

Just checked with some other machines I have handy, and the signal level is in the same range as the others, none is an outlier. Seems like something is off with your machine unfortunately, as you have tried everything that comes to mind.

I’m on BIOS version 3.06. I have also have the correct / latest drivers. Here’s a picture of the framework laptop next to a macbook air, both ~10 feet from the router (not my router, this is at a friends house). I would just upload a screenshot from each laptop but I wanted to show that they are side by side in the same location. You might need to zoom in to see the download speeds:

The Framework (left): 42.3 mbps download
Macbook Air (right): 60.0 mbps download

Edit: While this might seem acceptable, keep in mind I’m 10 feet from the router. Increasing the distance from the router greatly increases the gap in download speeds.

I’m having a similar issue here. I have the Framework Laptop with the Intel AX210 module side-by-side with a Dell Latitude 5500 with an Intel Wireless-AC 9560 and the Dell is getting twice the download speed. As far as I can tell the Framework’s antenna cables are connected properly. Is there any diagnostic test to see if the antennas are connected properly other than opening up the laptop and unplugging either one of the cables?

Are they the right way round. There is a order.

Yes, I believe they are. The black wire is above the white wire.

For my router, I use a Asus RT-AX88U with WiFi 6. The router is on the first floor and my Framework laptop is on the second. Several walls and the floor to go through. No problems at all. About a dozen devices are connected to the router including a 4K security cam.

If another laptop is getting better throughput than your Framework, perhaps you need to match the router to the laptop (new router purchase) or there are some router settings that can be fine-tuned.

Special settings in router such as game profiles, traffic analyzer, etc., can limit performance. Consider disabling them.

Is the router firmware up to date?


I’ve noticed poor range as well, as an electrical engineer, my first take-away is that having a large piece of aluminum right in front of your antennas are going to seriously hamper RF performance. I wish they would have incorporated a little plastic RF window or something.


I have the same issue. I only really noticed it when I was out of state at my parent’s house where I am about 50 feet away from the router and with a door shut, I get 2 bars and on my m1 macbook air, I get full bars even all the way across the house and full speed, where on the framework the speed is lower. I even adjusted the antenna connectors on the wifi card to no avail.

Definitely also having this issue. Checked the cable connections, BIOS version, but not sure what else it could be. Using Manjaro. Windows-based work laptop absolutely fine, Framework keeps dropping the connection. Edit: First edition FW.

I know this is an old thread, but I am having the same problem on my Framework 12th Gen and the Intel AX210 Wi-Fi adapter.

I’ve been going back and forth with Framework support for almost a week. I get download speeds between 70Mbps and 120Mbps which is less half the download speed of all other Wi-Fi devices on my network. Weirdly enough, the upload speed seems to be fine, 380Mpbs to 420Mbps.

According to support, this is normal operation. I’ve had my Framework laptop for almost a year now, and this is the first time I’ve regretted my purchase.