[RESOLVED] Linux Mint Edge USB Installer not found

Curious to know if anyone has had this issue and if they resolved it.

The new Linux Mint Edge edition was released and I wanted to install it on my Framework 11th gen because I’ve had odd issues with the 6E AX210 No vPro wireless adapter.

I’ve had to manually force the 6.2 kernel on my machine when running the NON-Edge version, but I still run into weird issues where I have to force a linux-firmware re-install every time I get an updated kernel through updates.

I’ve put the ISO onto a USB stick to boot it, but the Framework doesn’t see the stick at all to boot from it. The 3 other laptops I tried the stick with found it, just the Framework does not. I do have the updated 3.19 BIOS installed as I needed it for the larger battery.

I realize this may be a Linux Mint forum question also but I opted to start here first. I also get that it’s somewhat of a niche issue but where the Framework isn’t recognizing a bootable USB stick is where I worry it’s a side effect of the BIOS update.

FWIW, secure boot is off in the BIOS.

Had the same issue, but with the SD card slot.
I got around the non-booting issue by using the new Raspberry Pi imager.
You know it will work once you tap F12 and the BIOS sees the media.
If that BIOS doesn’t see it, then there is something wrong.

Rufus didn’t work with Linux Mint, but did work with Windows 10 and 11.

Had to use Mainline to install a newer Kernel, since the GPU wasn’t supported in the Linux Mint Edge edition. (just caused errors about missing firmware)

Have you tried the USB stick in all of the Framework’s ports? I’ve noticed (especially with USB 3 storage) that my Framework can be flaky in recognizing and mounting devices. They will work sometimes in some slots and not others.

Forcing a USB 2 speed connection (via a USB 2 speed dongle or cable) is another way I can get devices to show up when they’re having trouble.

@Howard_L / @brianshmrian - Thank you both.

I actually solved this about an hour after posting. In a similar vein of what @Howard_L went down, I used Rufus via Win 11 to put the ISO on the USB stick. I’ve used Rufus forever and never had an issue. I’ve even used it to install the non-edge version of Mint that I had on my Framework.

I grabbed another Mint laptop and used the USB Imager app, wrote the ISO the the same USB stick and it worked fine.

I never liked the Linux USB image apps as they make the whole USB stick read-only which is why I have always used Rufus.

@brianshmrian - I actually did try both USB-A and USB-C ports and got the same result on both. I didn’t try throttling down to 2.0 speeds tho.

Ironically I just went to launch Rufus again and it prompted me for the latest 4.3 release. Within that changelog I see the reference of a fix for LMDE. I’m assuming that meant the Debian Edition but who know, maybe a typo between LMDE and LMED. :slight_smile:

Regardless, I have solved the problem. I again thank both of you and I’ll update this as resolved. :+1:


Delighted to hear this has been resolved.

1 Like