Batch 10 DIY - Dedicated Video card already died?

I bought the Framework 16, w/ Dedicated video card.

  • Ryzen™ 9 7940HS
  • AMD Radeon™ RX 7700S
  • Crucial RAM 64GB Kit (2x32GB) DDR5 5600MHz
  • Corsair MP600 CORE Mini 2TB M.2 NVMe 2230
  • WD_BLACK 4TB SN850X M.2 NVMe 2280
  • Windows 11 Pro

It has worked pretty well, biggest complaint to date would be issues with the Power settings (Only Balanced Power is now an option, no option for Best Performance even when plugged in w/Framework power brick) and the fan’s being extremely loud (even for a gaming laptop) and not seeming to cool the system well enough without lifting it up another inch in the back. (Putting my ifixit plastic lid under the back feet to give it another 1/2 inch in clearance does crazy improvement for the thermals)

Anyway… I was noticing some FPS dips in games that ran fine previously (specifically D2R, @1440p, used to be like 90-120fps, now it was doing 19) and decided to look at AMD drivers, it was not recognizing the 7700s, it was using the integrated card. Odd I thought, so i looked in device manager, and the 7700s was not even showing up at all.

I thought it to be some weird software glitch, so I restarted the system, and after it shut down, it no longer posted.

It would just show the power button lit up, and no activity on the screen. After trying a few times, I noticed the flashing lights, but it makes no sense. The flash codes on the site indicate up to 12 flashes in the pattern, but I was seeing 99+ reds in a row, then 2 green and all red again.

I decided to go old school route, lets start removing things and seeing if it posts without things… So I removed a stick or RAM, and 1 of the NVME, and then swapped it out with the other RAM and the other NVME, nothing would post… so I decided ok, lets try removing the graphics card, and BAM system now posts. Great. Maybe it was a fluke, lets throw the 7700s back on, and try to boot again, nope, dead.

So now I am stuck here with a laptop without the dedicated graphics card waiting on support to reply, and you would think that isn’t that big of a deal, use the integrated card… but the system has no fans if you buy the dedicated graphics card, as they are both installed on the removable module. So now if I were to try to run my laptop, it would literally have no thermal cooling.

Trying to think of the silver lining, I know if I didn’t have a framework, I would have had no clue the GPU is what was shot… but it’s the same result, dead brand new laptop, with no idea where to go for next steps and no reply from customer support (probably because it’s a weekend and or they are swamped with pre-order questions etc)

I really wanted to sell my friends / coworkers on the laptop, but it is just hard to do now with this bad experience. I know all newer companies go through these things, and not all units are perfect, so obviously I will give it a second chance depending how Customer Service helps, but It has left a sour taste for sure.

Does anyone have any other advice on how to further troubleshoot it, or bypass the 7700 but still use it for cooling, while waiting on customer service?

Hmm. Certainly it was not clear to me in the purchasing process why one would want to spend $100 for just the “shell,” though going and looking at time of writing it does indeed indicate it contains “system cooling.” Pictures confirm that the non-module part of the system just stuffs heat pipes into that area.

I see they do sell the shell – but I’d have to be pretty thoroughly Done™ with support or in extremely dire need to spend $124 (w/tax+expedited shipping) on something that “ships within 5 business days.”

Now I’m curious if the graphics module, the graphics module heatsink, and the graphics module interposer could be removed, and replaced with the shell fan control module and shell interposer… the intent being to convert the graphics module into a shell.

I’d also be curious (though I probably wouldn’t be brave enough to try) if using the shell interposer – presumably with only the fan control connections – would be sufficient to get the fans working without the rest of the graphics module.

Certainly my preference, though, would be to work through support to get a replacement, and/or an official statement on how to get “backup” cooling (or if the system will safely throttle itself without active cooling of the heatpipes) if the graphics module is stopping the system from booting.

I bought the shell also during my purchasing process. This post does make me concerned though. I have issues getting my system to see the dGPU and is running on the iGPU. And I can confirm this by putting a gaming load on the system. All the heat comes out the side vents and none from the back vents. The only thing is, I’m running Linux Mint. But you’re running windows. I could shrug it off and think it’s just a Linux thing and a fix will come shortly, but now reading about yours might being dead makes me concern about mine.

Did your dGPU ever show up in your system? I received my unit April 19th, and it worked fine with the dGPU showing up until Friday, then the reboot seemed to seal the deal (Fans were still working fine while it was using iGPU to handle graphics, but after the restart, it won’t post with the unit so I can’t even use the fan’s anymore).

If yours never show up, it could be a Linux thing, I am not too familiar with Linux, but if it all of a sudden disappeared like mine did, then I don’t know. I don’t want to speculate, I hope yours doesn’t go down the same path mine did, I want Framework to do well, and grow.

What Batch was yours?

Mine is Batch 12. And no I don’t think it ever showed up. It only see the iGPU. It could be a Linux thing and just need to do some more digging. Just everything I tried so far that should make Linux used the dGPU hasn’t worked like it doesn’t exist. This is the first time I decided to use Linux as my daily driver though. I’m just hoping it was growing pains and not anything to major.

The AMD GPU should show up under lspci, even if you don’t have a new enough kernel or firmware packages to drive it.

Hi @Matt_B,

That is frustrating your AMD graphics card stopped working on your FW16.

I did not order mine with it; though I remember early on people were asking what the extra part in the box was. It was the Interposer for changing from the AMD graphics module to using the basic module with fans.

If they made the interposers pinout differently (which I presume otherwise why include them) maybe that one doesn’t connect to the AMD module and just powers the fans on the module?

The regular FW16 controls those fans, I do not see why the FW16 with the AMD module would not control them as well. In laptops, when you get one with AMD or NVIDIA graphics they don’t include extra fans; the cooling comes from the standard fans in the laptop. Presumably this is the same case here; where the interposer connects the external graphics module and the power to the fans in the module.

This is obviously not a normal test case; though it would solve the situation you have where the system will not POST with the AMD module and you didn’t buy the regular module so you have no built-in cooling. The alternative is to figure out some external cooling to blow across both heatsinks; though this certainly ruins the portability of the machine.

This is a bit of a stretch, just trying to think of a way for you to have a functioning machine until they can RMA the AMD module. Understandibly, more warning should have been presented in the ordering screen that it is highly recommended to purchase the regular module in the event a scenario like this does come up.

Framework is unique in that I can not think of another laptop manufacturer that offers the modularity; if you had a Dell, HP, Apple, etc. laptop your machine would just be toast until it could be repaired or replaced.

1 Like

I appreciate the attempt. I just tried to power it on today without the interposer but with the AMD Expansion on, the fans get no power without the interposer, and with the interposer+GPU it won’t boot, so there isn’t a way to use just the fans of the AMD Module.

yeah, there seem to be something wrong.
You contacted support?

Yeah, made a ticket on Friday. Still haven’t heard anything.

EDIT - Support has responded, and I am working with them. Thanks for the help guys.

It’s hard to differentiate between the CPU (or technically APU) and the GPU. I can copy and paste the information from the terminal. I might need a second pair of eyes on it to see if I’m missing something.

lspci | grep VGA
You should see the iGPU (Phoenix1) and the dGPU (Navi 33) both show up.

[Easier to give the exact values now that I have my own in hand…]

Doing it with lshw:

smurphy@jupiter:~$ sudo lshw -C display
       description: VGA compatible controller
       product: Advanced Micro Devices, Inc. [AMD/ATI]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: /dev/fb0
       version: c1
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=amdgpu latency=0 mode=2560x1600 visual=truecolor xres=2560 yres=1600
       resources: iomemory:840-83f iomemory:860-85f irq:121 memory:8400000000-85ffffffff memory:8600000000-860fffffff ioport:a000(size=256) memory:90d00000-90dfffff memory:90e20000-90e3ffff
       description: VGA compatible controller
       product: Advanced Micro Devices, Inc. [AMD/ATI]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:c5:00.0
       logical name: /dev/fb0
       version: c2
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list fb
       configuration: depth=32 driver=amdgpu latency=0 resolution=2560,1600
       resources: iomemory:860-85f irq:87 memory:8610000000-861fffffff memory:90000000-901fffff ioport:1000(size=256) memory:90500000-9057ffff

Glad to hear you are working with Support @Matt_B.

Maybe it was not clear on my message before; did you try the other interposer that came with the laptop and was in the box?

That one is suppose to be for just the shell but they were including it with people who ordered the AMD graphics card so they would have it on hand if they bought the standard shell with fans.

(Maybe I am getting this all mixed up and the extra one was the one that came with it for the AMD module?)

I guess the TL:DR is; did you try it with both interposers and get the same result?

Let us know what goes one. Enquiring minds want to know :slight_smile:

I only have the 1 interposer, so I was unable to try with another.

i had pretty much the exact same thing happen to me.

you cant really bypass the 7700s. i was able to remove the battery, hold down the power button, then put the battery back in (all modules except the graphics card removed, no external power) and get it to boot two times like that before it stopped working.

support will replace it (the graphics module plus interposer) for free but expect to be stuck without a working laptop for a while.