Blue Screens on 7040 Series

Has anyone been having any issues with blue screens? I’ve had 4 since getting the laptop about a week ago. Just trying to figure out if it’s my error or an issue others are experiencing before I diagnose too deeply.

Samsung 990 Pro
16gb RAM (the kit that you can buy with the laptop, not sure of the brand)


That sounds like a lot, I’ve only had one with my 7640u when I was trying to do something in Adobe Illustrator. Given this is a relatively new platform on AMD I’m going to chalk mine up to driver issues, but the error message and event viewer items I don’t remember being particularly helpful when I tried to diagnose the cause.

You might want to consider running a RAM stability test to rule that out if you haven’t already.

I had one the other day. At first my trackpad wasn’t responding and then I got the BSOD.

Ryzen 5 7640U
Crucial P3 Plus 4TB PCIe Gen4
Crucial RAM 32GB Kit (2x16GB) DDR5 5600MHz CT2K16G56C46S5

Thanks, I’ll run that later when I get the chance. I took a quick look at the dmp files generated after the crashes and every error but one was DPC_WATCHDOG_VIOLATION, except for one which was PF_DETECTED_CORRUPTION (which was an easy fix).

Based on those, it feels like driver issues to me as well.

I’ve gotten about four to five BSODs by now. Most happened during or soon after Windows installation. At least one happened while just using the laptop.

Solidigm P44 Pro
2x 16 GB DDR5-5600 CL46 from Crucial
Windows 11 Pro

I’ve gotten two BSODs as well with the DPC_WATCHDOG_VIOLATION code. Both times I was just using a browser, so it doesn’t seem particularly correlated to anything. I was using the 3.03 BIOS and associated drivers, and I’ve since upgraded to the latest (non-OEM) drivers from AMD, so we’ll see if that helps.

SK Hynix Gold P31
Crucial 2x16 GB DDR5-5600
Windows 11 Home

I was thinking of trying the latest AMD drivers as well, but I wasn’t sure how much that’d do. Please let us know if that works for you. I’ve gotten a few more blue screens but they’re mostly happening during light browsing for me as well, no consistent cause I can tell.

I was having bad BSODs until I cleaned the contacts of the ram I was using aswell as reinstalling the drivers that framework provides directly.

EDIT 11/6: I was still having issues with BSODs but once I used the autodetect tool from AMD directly it has sine stopped.

1 Like

I had the same issue with my prebuilt, so all the hw should be suitable.

I bought the framework as a replacement to a ryzen6000 series Lenovo and that had exactly the same issue. The "DPC_WATCHDOG_VIOLATION“ is indicative of the AMD GPU. The 6000 is 680M, so figured it might have been a bug AMD would have fixed by now. Clearly not.

I’ve only had one so far (just moving the mouse with no other workload) which seems slightly less frequent to the other machine, but it does mean doing any productivity on it can be risky.

1 Like

Just a heads up after i installed the software from directly I was still having issues these were fixed when I ran the AMD auto detect drivers from AMDs website. I will update my orignal comment to reflect that.


I’m still occasionally having these crashes with the new drivers, but it’s far less frequent.

Yeah i hate to say it but I’m still crashing just once every 4-6 hours instead of 1-2

I get at least 2 BSOD a day. Seems to happen more often when I’m running VsCode --but that’s often what I’m doing on the laptop. Since it’s so new, I suspect this will be solved with future updates and firmware.

I’d be happy to give the team the event logs.

  • Ran a memtest the day I set it up. No errors (~5 hours).
  • Ran a performance test against the whole machine. Stable (~2 hours).
  • Windows Pro 11
  • Only hardware I didn’t get from Framework was the SSD. MSI Spatium m480
  • Oct. 31 firmware
  • I also run a lot of virtualization

Having a similar issue. Usually the laptop just freezes and I just hold down the power button to force shutdown it. This time touchpad stopped working, but keyboard kept working and Windows was in a weird state: shutdown command didn’t do anything, Alt-Tab didn’t work, task manager was able to start, but never got to list any processes. After a minute or two it finally has shown me BSOD with DPC_WATCHDOG_VIOLATION.

1 Like

For anyone coming by with similar issues, updating to the 3.03 bios and the new drivers fixed the issue for me. I haven’t had a crash since

My first post:

Since going directly to AMD and downloading the drivers, I have not had a crash over 5 days. I have the AMD Ryzen 7 7840U.

Here are the direct links:

That’s the Oct. 31 update and that didn’t fix the BSOD as per my first post. But you have AMD Ryzen 5 7640U.

In case it helps anyone…

Sadly having this issue on my laptop.

Running a 7480U, Samsung 990 Pro and Kingston Hyper X 5600. Bluescreens that happen every few days to every couple hours. Most give the same stop code above, Bluescreenview points to NTOSKRNL. Hoping to see if anyone had any fixes or similar issue.

Samsung Magician reports no issue with the drive, memtest and Windows Memory Diagnostic found no issues with the RAM. Always seems to happen whilst web browsing or on Discord. Laptop locks up, a few seconds later a BSOD appears