Bluetooth Keyboard delay

Hello, I received my laptop today and aside from the excruciating process of installing Windows I had a fairly easy time installing setting up the laptop!

There a hiccup with a thunderbolt 3 dock, but I posted it in the TB3 dock megathread.

My issue is with my MD770 Bluetooth keyboard. The first key press (and the press after 5 seconds of not using it) is delayed by half a second. I have also seen some stuttering/duplicate letters.

Works fine with my work laptop and the my old laptop I am replacing.
Using DIY Windows 10 with 1165g7.

I did not find anything in the community threads on this issue, but I might have missed it.
Has anyone else experienced this issue?

1 Like

I’m having a similar issue with my bluetooth mouse (Logitech MX Anywhere 3 Wireless Compact Performance Mouse).

Is there a bluetooth setting we can change on the Windows device manager settings to modify the latency of these devices when they aren’t used for a little bit?

1 Like

I’m having the same issue with a Logitech MX Keys. Reading about similar issues with other laptops, it sounds like it might be a wifi driver issue.

1 Like

There is apparently a strange interaction of some kind between Windows 10 and the AX201 and AX210 around idle. The feedback we got from Intel is that this is resolved with Windows 10 21H2, and the preview builds we tested earlier did seem to resolve the issue.

8 Likes

Thanks nrp and Corey! Didn’t see the post Corey made that linked to the thread.

I’ll update drivers from a couple of comments I saw in that thread and update accordingly.

I also experienced this with a Logi M575 BT trackball I was using when I set mine up. Unfortunately I used 21H1 with my setup, and not 21H2.

No luck.
Updated Intel Wireless Bluetooth from 22.40.0.2 to 22.70.2.1.
Updated Intel Wi-Fi 6e AX210 driver from 22.40.0.x to 22.70.0.6
I also tried disabling the Bluetooth HID Device driver power management properties.

Any other leads?

I was able to figure it out!

I followed these instructions to disable USB Selective Suspend settings in the Advanced Power Options.

I also needed to follow these steps (Step 2 worked for me) to display the setting I was looking for by editing the Registry.

6 Likes

I’m having the same issue with a Bluetooth mouse (Logitech MX Vertical) and unfortunately @TheChonch’s suggestions had no effect. I will try upgrading to 21H2.

After successfully upgrading to 21H2 (via this enablement package), and also disabling USB Selective Suspend, the issue is somewhat improved. It occurs less frequently and with a shorter delay when it does. Neither the upgrade nor the configuration have an effect alone; you must do both. Regardless, the issue is still present.

Thanks @TheChonch, Can confirm this fixed my BT Mouse on Windows 11!

1 Like