Cannot find boot device

Trying to install win 11. Usb and ssd are recognized in boot menu but does not see usbs iso, or its rufus setup. I got my FW16 today.

I am getting the Error message “Default Boot Devce Missing or Boot failed. Insert Recovery Media and Hit any key. Then Select ‘Boot Manageer’ to chooose a new boot device or to boot recovery media.”

The boot manager is completely empty.
I am using the WD-Black SN770 1TB

Following this guide. Windows 11 Installation on the Framework Laptop 16 DIY Edition - Framework Guides

Well I tried updating the drivers on the SSD. Got the firmware up to date, however no difference while trying to boot.

Tried every port for the usb. Ordering new usb to try to boot off of.

Share Pic of Bios pls look for settings like usb boot secure boot

Change boot order to USB its there in the BIOS

and maybe try to disable the quick boot and Quiet Boot

Im not sure where boot order is on this bios.

The boot manager and boot from file are empty.

New boot device prority ive tried auto/first/last

Just create an boot stick with the media creation tool and check if it is FAT formated

Yay! This was it i needed to use windows media creation tool, just the iso or the Rufus boots did not work for me.

1 Like

Grate news hope you can enjoy the Laptop.