USB drives not showing up in BIOS or Boot Manager

Hi everyone,

I just got my 11th gen i5 DIY edition. I want to install Windows but I always get the message: Default Boot Device Missing or Failed. Insert Recovery Media and Hit any key. Then Select ‘Boot Manager’ to choose a new Boot Device or to Boot Recovery Media. After that there is nothing to choose from in the Boot Manager.

I used two diffrent USB Sticks, both ‘flased’(if this is the correct term) with the official Media Creation Tool from Microsoft. After both failed to show up, I flashed on of them again, but this time with Win 11 instead of 10, but still the same problem.

Before that I was browsing the forum and found some topics about the same issue, and I disabled Secure boot, checked if USB boot was enabled, change boot order away from auto, increase the timeout timer and remove all unused expansion cards.

I also noticed that the BIOS only showed my installed SSD, my USB drive wasn’t in that list.

I would really appreciate if anyone could help me out.

Thanks in advance.

1 Like

Have you tried using the Windows Media creation tool to make a .iso file, then used another program like Rufus or Etcher to make you bootable USB? I’ve had a few times in the past where my laptops didn’t like the bootable usb that the media creation tool made.

I tried it with Etcher and Rufus now and also used another PC to flash the drives, but still nothing shows up in the BIOS :confused: . Is there another way?

Sounds like there could be a greater issue? At this point it may be more helpful to contact support and see if they have any recommendations.

Seems like you’ve tried all the reasonable steps.

For whatever it’s worth, have you tried using a “newer” flash drive? I’ve sometimes experienced this behavior in older drives. Try a drive that supports USB 3.0?

Also try redownloading your source ISO? Might have bad checksums.

Whats the capacity of your thumb drive? Everything above 32GB could be problematic. The drive needs to be formated as FAT, which only supports 32GB max.
Not sure about this, but i would assume, that the Windows Media Creator already does this.

Another thing you could try is to disable “Quiet Boot” and “Quick Boot” in the bios.
Not sure about this, but this may prevent USB devices to be initialized.

Have you tried booting the installer on another pc?

I made a new Boot device at work today. I used my SD card with an USB 3.x SD Card reader and disabled Quiet Boot and Quick Boot.
It finally worked. Windows 10 is running smooth now.

Many thanks for all your help.

6 Likes

I am having this same issue. Boot Menu doesn’t show the usb boot device.

What have you tried so far and which os do you want to install?

I have run into comparable issues. Try to switch the extension card slot and try to plug/unplug USB pen drive multiple-times. Or plug the USB Pen drive first and than start the notebook.

I’ve got two USB extension cards, and the boot-able USB pen drive is sometimes recognized and sometimes not. At one extension card slot it seems to be more reliable than on the other. I tested with two different USB Pen Drives and different Linux ISO Images (Arch, Gentoo, Ubuntu).

I’ve got a DIY 12th edition and I’m having what I guess is the same issue. Nothing shows in my boot devices. I have tried two separate 8GB USB drives created with the MS tool. Both work fine on other machines but nothing here. I am a bit covid brained at the moment so maybe it’s something obvious that I don’t understand. But trying the USB-A card in all 4 slots did nothing. Multiple attempts at plugging the drive in did nothing.Changing New Boot Device Priority did nothing. I also tried a USB DVD drive but no joy.

I really want to love this machine but am currently frustrated. Advice gratefully received

Ah, sorry that doesn’t sound good.

Did you try other tools than Windows Media Creation Tool? Do you try to install Windows 11 or 10? You’re trying to install Windows, don’t you?

To pinpoint that it could be a hardware issue:
Could you try to flash a Linux ISO with Rufus or Etcher and try to boot? Do you have another USB extension card, or only one? Should you have more than one, did you try with another card? Can you attach the extension card to another laptop or hub and access an USB Pen Drive?

Did you change anything in the BIOS, especially in regards to Safe boot and TPM?

After reading through more of these replies, I realized that I’ve had this exact experience myself. A possible temporary solution that worked for me was to plus the USB drive into a dongle or USB hub, which for some reason made it show up in my boot devices. Hopefully the Framework team is looking into this and can figure out a fix in the future, but hopefully this workaround can help some people out until then!

1 Like

Literally just dealt with this about 2 hours ago. Plugging usb thumb drive in to usb port did not show up in the boot manager. I tried plugging it in to a usb c adapter and it then recognized it. Worked like a charm after that. Not sure why. But that is a solution for now

2 Likes

Hello everyone, I just got my framework 12th gen laptop in the mail today but it’s not showing any of the usb devices even though it’s working fine booting on another machine, I have tried removing the usb and reconnecting it and it’s showing on attached devices in the bios. I have tried using a usb c dock and also the usb a port on a different adapter I even went away to install a ssd into another machine and install windows and it’s still not booting to this please help