Cannot shutdown Framework properly (Ctrl+Alt+Del or simple Shutdown Click does not work)

Hi there,

first of all to make things easier: I don’t installed any SSD right now. So this behaviour happens also to USB Linux distros, to the BIOS menu and the boot menu.

The problem: My Framework does not shutdown properly. It freezes on reboot or shutdown or it shows a black screen.

If I go to the BIOS settings and want to Save and reboot → black screen.
If I do Ctrl+Alt+Del in BIOS or boot menu → it freezes.
During the BIOS update (I tried to updated 12th gen BIOS to 3.06) it also freezes when it wanted to reboot.

I cannot find anything useful on the internet yet.

Things I tried:

  • Different SSDs and OSes… but this behaviour also occurs in BIOS menu, so I guess it’s either a Windows or Linux problem.
  • Fully BIOS battery reset using the guide
  • Updated BIOS from 3.05 to 3.06 (same behaviour as before)

What I have:

  • Intel 12th Gen i7 1280 Framework DIY Edition
  • 32gigs of Ram
  • Original USB-C power adatapter
  • As already mentioned: BIOS 3.06 right now.

The only thing that works: Holding the power button for a couple of seconds to get a hard shutdown. But I guess it ruined my SSD already (I ran multiple times fsck to get my data back from it…).

Do you have any advices?

Try to reset the motherboard (use the wiki instructions), and if the problem persists, that may be a hardware problem on the motherboard. You should also contact Support, they will guide you through the diagnostic steps (it can take time, but that’s worth it).

Yes, I already tried to reset the motherboard using this guide.

Ok, in this case you should contact Support. It will take some time to do again with them all the diagnostic steps, but believe me that’s worth it. If you are still under warranty, in the event they determine that the problem is hardware and that it is not a “customer induced damage”, then you’d have a good chance to be proposed a free mainboard replacement.

I have contacted the support. I will let you know if there is anything new.

But… I discovered one more detail:

  • I’ll see a black screen while on battery (Ctrl-Alt-Del, simple press on bower button or software reboot).
  • Screen freezes while plugged in (Ctrl-Alt-Del, simple press on bower button or software reboot).