Cant Connect to Monitor and other Port Issues

Using Fedora 35, with the Framework i5.

I recently bought a 27" Dell Monitor (U2722D) and tried to connect using my spare Display Port (laptop) → HDMI (monitor) connector, since I don’t have an HDMI port on the laptop. What’s happening is that the monitor can see that my laptop is connected, but it is not getting a signal from it (“No HDMI signal from your device”). I read on here that it could be a compatibility issue, since these are essentially USB-C, and would need an adapter. So, I used a normal HDMI cable on the monitor with a display port adapter plugged in to the laptop, but still the same thing, “No signal from your device”.

As of now, my laptop can’t see the monitor at all. It is also having issues loading USB devices. Usually restarting works when that happens, but I’ve never gotten it to recognize the monitor at all. Any advice would be appreciated.

1 Like

Have you tried reseating the expansion cards?

If you run wlr-randr, do you see multiple monitors or just one?

Hello. I have reseated them. I also can’t use that command.

compositor doesn't support wlr-output-management-unstable-v1

Okay, so let’s see if sway (a different Wayland compositor) recongizes the other monitor.

  1. Install sway.
  2. When logging in, select sway as the session.
  3. Re-run wlr-randr at the terminal (the default keybinding for opening up a terminal emulator is Super+<enter>).

Just trying to see if this is a Gnome problem or something lower down on the stack.

1 Like

Hey, thanks for the help!

I’m not sure what happened, but I installed sway, and then re-seated my DP slot again and it worked. It may have been what you initially stated. Just needed to reseat (and reboot and update). I still got the same output as last time, so I may not have chosen the sway session. But all is well.



Good to hear it’s resolved!