Charger flexibility? (spoiler: YES 🙌 )

I use a 33W charger to charge my Nothing Phone (1), it’s very fast to load up a phone.

I tried to use it to charge my 11th gen DIY Framework laptop.

  • I got the red led near the USB-C
  • Ubuntu Gnome does not say it’s charging

What are the expectations?

  1. Does Framework laptop accept any USB-C charger, from 5W
  2. If battery is charging, should the LED and the OS tell me that it’s charging?
1 Like

I wouldn’t rely on the gnome charging indicator tbh. I have a monitor with PD built in and it trickle charges my device without gnome telling me it’s actually charging.

The only indication that it’s charging is the time until battery depletion goes up to like 40 hours!

I think the FW powers at any wattage but only indicates at like 45 watt that it’s actively charging to avoid confusion between charging the battery and only having enough power for the battery not to deplete.

Hope this helps! :relaxed:


The Framework can charge from any USB source from 5-20V, but your laptop may be drawing more energy than what’s charging w/ weak/non-PD chargers. On Ubuntu, the Gnome power utility package I believe is called gnome-power-manager and provides the gnome-power-statistics app. You can also use upower directly which should give you an accurate description of whether your battery is charging or discharging, and the rate its doing so.


:raised_hands: @Cheese & @lhl !
thanks for sharing your experience and resources.

I’ll try to use the 33W longer (when FW laptop is fully down) to see how fast it charges up.

For the Ubuntu UI bug,I’ll try and dig deeper (but not a big deal for now). I could only find gsd-power as a running process.

Context: when I close the lid, battery goes down quite quickly (about 15% during each night). I’m on BIOS 3.07, considering to try the EFI Shell recommendation to move to 3.10, but trying to be more confortable with my new env before trying this.

@Matt_Laurenceau I would definitely move to 3.10 and on top of that, if comfortable with beta firmware, I would flash the beta firmware for displayport expansion cards if you use one. Both actions should improve battery life/power draw.

1 Like

I have used the following without a problem,

  1. 100W charger
  2. 65W charger
  3. 20W charger
  4. 5W charger
  5. 20000 mAh Powerbank (that is rated at a maximum of 3A at 5V)

1, 2, 3 and 5 while actively using the laptop without any problem continues to charge the laptop (while compiling or light gaming).

4 charges the laptop when I am in tty mode without X running or when in suspend/sleep (I don’t recall currently which specific state).


Merci @GhostLegion :raised_hands:, I’ll go with EFI shell 3.10 upgrade (I was concerned initially with issues that some people had in Aug)

Don’t have displayport (only USB-C+A, HDMI and microSD), so I’ll not play with this beta

1 Like

@5uie1 thanks a bunch for all these examples! (very clear story)

Regarding #4, did you see an improvement for suspend by moving BIOS to 3.10? (that’s my main concern with Intel 11th gen)

1 Like

Apologies, I did not test with respect to the charger, but moving to 3.10 from 3.07 was definitely helpful for me on my 11th gen i5.


Actually, the top-right gnome battery icon does mention it charges, it just took a couple of seconds to refresh

Note: I also upgraded BIOS to 3.10 since (using EFI shell, worked great). Unfortunately did not change battery consumption when in suspend state

1 Like