Framework only shows power indicator with low power charger

I have a diy edition 11th gen i5 laptop, a while ago I lost my official framework charger and I have been using a cheap aftermarket 45 watt usb c charger. Today I realized that neither of the 2 laptops I would charge with this aftermarket charger would consistently charge. I thought this might be because the hardwired usb c connector on the charger must be wearing out, however when I tried either of the laptops with a variety of other chargers they would not power on. I tried the framework laptop with a low power 15 watt charger and the charging indicator would light up but seemingly show an error code. If anyone has any advice on this please let me know.

Hi any of the chargers do not have the ability to use the PD protocol they will stay with the initial 5V charge.

The way the 5V charge is supplied may well be that it doesn’t provide enough power, especially if the laptop is powered on.

I tried a few 30 watt chargers that charged the laptop in the past and they didn’t charge it either. I also tried a different pd charger that was either 45 watts or 65 watts and that didn’t work either.


When you say not charging do you mean not charging from some state of charge or not charging at all as in not being able to power on?

If the later see


The laptop will not boot, no fan spin, display off. The charging indicator will not turn on with a regular pd charger, the charging indicator will show an error code with low power 15 watt usb a to usb charger.

Sounds similar to a depleted ML 1220 the RTC|CMOS battery.


This has been resolved, I used a 5 volt charger to initialize the laptop then plugged in another 45 watt charger and the laptop worked.