Default Boot Device Missing or Boot Failed

My framework laptop (DIY) suddenly reports
'Default Boot Device Missing or Boot Failed
Insert Recovery Media and Hit any key
Then select ‘Boot Manager’ to choose a new Boot Device or to Boot Recovery Media’
I had this problem a week ago, I realized that the SSD is not recognized by the pc.
I sent an email to the framework support team. They acknowledged the receipt of the email and nothing else.
I thought I have a warranty and hoping to get a replacement for my failed 1 TB SSD. My laptop is part of the 4th laptop sent out.
Any advice for me?
Thank you.

Did you update to BIOS v3.07? If you did, it clears the boot entries and you need to re-add them manually.

Yes, I just updated Bios to v3.07 with this guide but still have the same issue of Default Boot Device Missing or Boot Failed
Thank you

Is this a Windows machine? If you don’t have boot media to recover with, you can access the startup repair menu by interrupting the boot sequence three times. More: How to use Startup Repair to fix boot problems with Windows 10 | Windows Central

This is before even that @BluishHumility, it doesn’t even boot to Windows. You need to enter the BIOS and re-add the Windows Boot Loader provided it’s still there or completely reinstall the bootloader.

Thanks. How do I re-add the Windows Boot Loader.
My PC because it doesn’t pass the bios check test before it reports the error of Boot failed

You’ll need to enter the BIOS, the key is F2 and navigate to the EFI Boot Order tab. If the Windows Bootloader doesn’t show up then you’ll need to use recovery media to reinstall the bootloader. If it’s the latter, then searching the internet should show how to repair your bootloader using a windows install media.

Thanks. I tried using windows media via USB but the pc runs into a blue screen when trying to load the windows to enable the bootloader repair process.
I think the SSD is damaged.
Unfortunately, I have sent an email to Framework for a possible replacement but no response yet.

Hello all. I experience similar behaviour:

  • Framework Laptop DIY
  • Storage: WD Black SN850 1000GB
  • OS: Windows 10

Problem description:
When the Laptop is running I experience random blue screens showing “Default Boot Device Missing or Boot Failed. Insert Recovery Media and Hit any key Then Select ‘Boot Manager’ to choose a new Boot Device”.
After pressing enter it shows “No bootable device – Please restart system”.
Then I can restart system without any problem.
This happens about two to three times per day. Any help?

Framework Support solved my issue. If you have a Western Digital SSD NVME 850 (or similar) try updating the firmware of the SSD: Download the Western Digital Dashboard and it will guide you through the process.


I have the same issue, but my SSD is up to date.

Framework 11th gen, Windows 10
BIOS Version/Date INSYDE Corp. 03.10, 7/19/2022
Firmware Version: 731030WD
Drive Health: Normal

Same here.
And regarding all the nice tips above: Recovery media and EFI boot setup does not apply if the SSD was not detected :wink:, which is obviously my case and others as well.

Had the same issue already when the DIY laptop arrived and could not recognize my old, but compatible, SSD. Only a change to the WD Black helped, until now…

Hello all, I have a similar issue with my 12th gen framework laptop running windows 11. I put on it the SSD from my 11th gen framework laptop and it worked fine for 9 months. But now the following appears.

When I start it, it displays: default boot device missing or boot failed. This, just at the start, before the start of windows.

  • I verified connection of the SSD. It’s fine.
  • I tried to boot on 2 different USB sticks but it freeze while booting on the USB stick.
  • The only way for me to boot successfully on the USB stick is to remove physically the SSD (WB NVMe SN850) from the laptop. But then I cannot repair anything on the SSD.
    Could you help me please? What should I do?

Fixed the issue changing the SSD…

I encountered this issue on Arch Linux as well.
However, I managed to work around it (for now) by using “boot from file”. Just go into your efi/arch folder and select the efi file there, that should boot you into grub as usual.

However, it is pretty annoying to do that every time to reboot, so I opened a support request. It’s not insanely urgent to me as I have my solution to boot for now, but I would like to not have to select “boot from file” every time I have to restart my machine.

@Philipp_D. Hate to bring this thread back up, but have you made any progress with your issue?

I am also running Arch Linux and have the exact problem and work around. Just slightly annoying when I boot up.

Nevermind. After trying some more things for the past 20 mins, I figured out a fix.

This issue came up when I switched my hard drive from another laptop with grub installed. I just had to boot into the OS and run the grub install command as outlined in the arch linux docs: GRUB - ArchWiki

Specifically, my command was:

sudo grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=GRUB2

I had an existing “GRUB” folder/file, so I just made a new one called “GRUB2”. After a reboot, it went straight into my OS.

I tried that out after reading this comment:

I have a similar issue. I’ve put together a Framework 13 (DIY Ryzen AMD) but cannot get passed “Default Boot Device Missing or Boot Failed”. I have a Windows .iso on a USB, but obviously no driver yet for the WiFi. It’s been many years (90s!) since I tried putting hardware together…