Ethernet Adapter Driver not working

Ever since I got my 12th gen Framework the Realtek USB GbE Family Controller has giving me a Code 10 error and not working with ethernet connection.
I am using a Wavlink usb-c docking station (link to it below) and downloaded the driver pack with it. This docking station has worked fine with my previous laptop.
I have already tried connecting it using different ports on my Framework and tried manual update from list of drivers with no luck.
Any help would be appreciated.

I’m the Linux Lead, so I may not be of much help here. Windows? What does the device manager show if it is Windows (again, my Windows knowledge is super dated). But this may help others help you. Also worth opening a ticket for this issue.

I did open a ticket a while ago but they tried and eventually couldn’t fix it. Also, Windows 11.

Ah, gotcha. Yeah as a dock user myself (Linux and USB-C), there are simply some instances where a dock simply will not cooperate.

Did they have you check the device manager? If they were unable to help, were you able to escalate the issue (responding and asking to do so to level 2 or 3)?

Yeah they had me go through device manager to try and fix it. They basically said to contact the manufacturer for the docking station and ask the Framework community for help.

Gotcha. Then yeah, this may be a driver issue. Since you indicated that you were able to get the drivers from the website, then it’s likely best to reach out to their support. I’d hit their level two contact link. Wish I had a better solution.