Expansion Card Oddity

An odd thing happened this morning.
I have the 1185, that I have set up with a primary boot drive on Windows 10.
I have two expansion cards, a 250gb that boots UBUNTU 21.04, and 1 Tb that I had planned to use as backup.

Upon receipt, both things worked, as expected. Both were initially recognized by Windows. After creating the Ubuntu dual boot, the 250 Gb was no longer seen by Windows (not a problem for me).
Starting yesterday, the 1 Tb disconnected and reconnected (File Explorer came up, showing the drive, without me touching anything).
Today, the 1Tb drive is not showing up at all for Windows, but booting Ubuntu, I can see the drive.

Removed the drive, attached it to a Lenovo with a USB-C port, this computer recognized the drive, everything I had copied was there.

Tried reformatting, on the Lenovo, no problems, then moved it back to the Framework. Windows still did not recognize it.

Any Ideas?

1 Like

Does it show up in Device Manager and Disk Management?

Not Now. It did before.

I installed Windows Subsystem For Linux and a Ubuntu VM this morning, but since the issue seemed to start yesterday, I don’t think that was a factor.

Additional Information:

I have an USB-C to USB-A adapter, so I connected the 1 Tb drive to the adapter, and put the adapter into the USB-A Expansion card.
It worked.
so still odd.

Update, after spending the day on the real job.

Looked at Device Manager and one of the USB Extensible Host Controllers had the inactive / not working icon.
Uninstalled it, scanned for hardware changes, came back normal
and now the drive is visible again.

Hmm, that is an interesting and odd issue. Let us know if it occurs again.

Of course, I will. Very happy with mine.