External display through HDMI seems to have limited colours (Win11)

Hello all, just received my Framework a few days ago and absolutely love it. Now I have connected an external monitor through an HDMI expansion card, I only noticed it didn’t seem the whites were all that bright and the blacks all that dark which seems very similar to what Nvidia cards tend to do with HMDI connected displays. Normally it’s a setting with them known as Limited and Full Range, so I started to search for that on the Framework in Windows’ Settings and in Intel Graphics Command Centre, but can’t find it anywhere.

I’m pretty sure it is limited, because if connecting my main PC to the monitor, the darks and brights seem quite a bit more prominent. Anyone know what else I could be trying?

Relevant specs are: Framework 1240P, HDMI Expansion card with HDMI to HDMI cable to a 1080p monitor.

Look for bit depth under display → advanced display!
It could be bandwith limited. It should be possible to fix it with CRU or Intel Graphics command center.
Alternatively it might be your desktop color profile having higher contrast/lowered brightness.

Says it has the full 8-bit, which is what the display should be. Desktop uses no alterations at all, as configured as I do fairly colour critical work.

That’s a contrast ratio (brightest vs darkest) thing. (Not so much about colours)

Did you import / add your external monitor’s icc profile? What’s the monitor?

Would like to revive this issue as I have more info now, it seems that the issue is indeed with the iGPU. I now have an eGPU enclosure, and with this device, the colours are showing correctly, the difference is night-and-day. Seeing as I the eGPU’s PSU already slurps 25 Watts on its own, I’m hoping to still solve this, though I fear the issue might be Intel related? Anyway, tried all the settings in Intel Graphics Command Center and none seem to affect the colours, something is still limiting the output.

I tried to find it, but I doubt this will help as it’ll just boost the existing output, not remove any limiters that are clearly present.

I don’t know if any of this new information is going to help to make a guess as to what is going on, but I’m asking again for help if possible, as this is very annoying as I want to be able to use an external display for digital art work.