External USB keyboard and mouse not detected

I know how it sounds like. Driver issue. But, hear me out. I have tried everything that I can think of. External mouse and keyboard is just not detected. I tried using a Usb C dock - nothing. Tried re installing all the drivers I could think of - nada.

The only that surprised me is when I updated my bios. It started working perfectly but then after I went to sleep and came back - nothing works anymore again. Any suggestions?

Hi @Hritik_Sharma,

Did the keyboard or the mouse work by themselves when plugged directly into one of the ports of the Framework without the dock? Not all USBC docks are made the same (especially the cheap ones).

You should just need to go to the BIOS screen to see if they are working. (Keyboard anyway) That will take the driver issue out of the picture.

Try moving the expansion adapter to another position and see if the same issues persist. If the issue follows your USBA connector it could be a bad expansion slot adapter.

You might mention your FW device:
Previous Firmware:
Current Firmware:


Please add which FW laptop you have. FW13 or FW16 and which version if its a FW13.
Also mention which usb ports you have tried it in. Some ports might work better than others.

Right, I believe it’s the back two slots that would work best. Something else to try is if the USB expansion card with the peripherals works on another device, e.g. plugging the USB-A expansion card into the USB-C port on your phone and seeing if the keyboard or mouse works then. Can help rule out the expansion card being the issue.