Fedora 35 installation: failed to start Switch Root

Hi there, thanks for the installation guide. I am having difficulties installing Fedora 35 on my framework laptop.

I have installed the Fedora Workstation 35 to a USB stick (using the Fedora Media Writer application for OSX).

I put the USB into the laptop and powered it on, selecting the test option.

I then saw the following:

The media check is complete, the result is: PASS.

It is OK to use this media.

[23.716152] EXT4-fs error (device dm-0): __ext4_get_inode_loc_noinmem:4449: inode #287167: block 1050139: comm systemd-fstab-g: unable to read itable block

(followed by 5 similar errors with different codes/numbers for comms: dracut-pre-pivo, mkdir, mkdir, dracut-pre-pivo, systemd.)

[FAILED] Failed to start Switch Root.

Warning: /dev/disk/by-label/Fedora-WS-Live-35-1-2 does not exist

Warning: /dev/root does not exist

Followed by some information on where the logs are and how to see them, as well as a notice informing me that it is entering emergency mode.

When given the option

Press Enter for maintenance

(or press Control-D to continue):

I pressed Control-D in the hope of some magic. But of course I got 6 further errors and after that it accepts no input (so I have since turned the laptop off and on again etc) The highlights of the further errors were:

ln: failed to create symbolic link ‘/run/initramfs/livedev’: File exists

dracut: FATAL: Failed to mount block device of live image

reboot: System halted

Can you please advise on what I should try? For context, I am a beginner to Linux.

I can upload photos and/or write out more of the logs if that would help.

Thanks in advance!

Did you disable secure boot in the BIOS menu? It has to be disabled to successfully install most Linux distros.

It may be worth just re-flashing the USB. Every once in a while a ISO can flash badly for no (obvious) reason.

Don’t forget to verify the checksum of your ISO–this can help eliminate a download error from the list of things that can go wrong.

Fedora Media Writer is very reliable in my experience, but if you give it another shot and it doesn’t work then I recommend switching to Ventoy and seeing if you have better luck.

If it still isn’t working, I would try a different flash drive–sometimes a few tired cells can spoil an installer.


Thanks for your reply !
After checking downloads, disabling secure boot I still had issues. Ventoy wasn’t an option from MacOS so I didn’t try that. But after finding that Ubuntu also didn’t work I changed my USB key, flashed it with Fedora Media Writer as before and installed it successfully (secure boot still disabled, assuming the BIOS doesn’t reset after turning it off).


Glad to hear you got it installed! :blush: