Fingerprint Device Dies on Windows 11

12th gen Framework using Windows 11. Every conceivable update installed. The version of the fingerprint driver I have is 3.12804.0.170.

The problem I have is that the device often dies with error: “Windows has stopped this device because it has reported problems. (Code 43)”. The event log also mentions it under Event ID 10110 with the text: “A problem has occurred with one or more user-mode drivers and the hosting process has been terminated. This may temporarily interrupt your ability to access the devices.”

Sure enough, the device has a warning symbol on it in the device manager. I can get it working again by disabling it and enabling it.

My current strategy to address this is to make a bat file that has the following inside:

pnputil /disable-device "USB\VID_27C6&PID_609C\UID9EFAE145_XXXX_MOC_B0"
pnputil /enable-device "USB\VID_27C6&PID_609C\UID9EFAE145_XXXX_MOC_B0"

This program (when run with administrative rights) gets the reader back online. I now need to figure out a way to get it to run at the right time.

I’m using the windows task scheduler to run that program with Administrative rights. So, the trigger for this action is “On an event”. I enter “System” for Log, “DriverFrameworks-UserMode” for Source and “10110” for Event ID.

We’ll see if this works. I’m posting this in case someone knows of an easier way to solve this problem. I’ll report back if this works.


I had this same issue and deleting the biometrics db then reregistering a fingerprint has so far solved the issue for me. It’s probably been over a week since I did that and haven’t ran into it again.

Thanks for the suggestion. I’ve deleted that db file a couple times per support request (and re-enrolled my fingerprints) but I still land in the same place.

1 Like

Well, that didn’t work. Going to think of another approach.

**Correction: I think it is working. Originally, the task was still marked “running” so it couldn’t be started when needed. I stopped the task and told windows to kill the task if it lasted more than an hour next time. It seems to be working as I could finally use my fingerprint reader in the morning after suspending through the night. The task history shows that it has been triggered.

I’m having this issue on an 11th-gen system. This system was working before I messed something up and needed to wipe & reinstall. The original install was Windows 10, upgraded to 11. This time. I installed straight to Windows 11. I haven’t been able to use my Fingerprint for more than one day at a time. I’ve removed the .db file and it works for one day or something, but then it stops working. I’ve had no issues with this laptop under Linux; using either Archlinux or Manjaro. This is getting annoying; I’m fairly certain it’s software though. Any other suggestions?

Do what I did above. It worked for me.