Framework 13 12th gen screen not switching on/system not working

Hello there,

I am running a Framework 13 12th Gen with Manjaro Linux and things were working great, except for some minor heating issues and some shortcut support issues until yesterday. I was running Manjaro LTS with KDE and Plasma 6 (x11). I closed the lid yesterday night, and when I opened it today, it wouldn’t load the boot screen properly and let me in.

So, I force shut down and tried restarting the computer and the computer would not even show the framework splash screen.

I would really appreciate any input as I love and depend on the laptop and I don’t want to end up with a brick overnight.

So, I have tried the following steps:

  1. Tried to check if the screen works by reseating the display cable (NO CHANGE, but I couldn’t figure out whether this was a problem with the screen or something else)
  2. I removed the SSD and then the screen came up saying, no bootable media. (So, screen seems to be functioning)
  3. Check if RAM is the problem by removing it and then putting it back one by one (in Slot 0) and then both in as well.
  4. I even tried fully resetting the mainboard state as shown in the guides.

Each time, the screen remains blank and nothing loads, no BIOS screen, no splash screen, nothing.

Instead, the side LED blinks the codes:
12 greens for each initialisation, followed by the orange, then Post Code bit 0 is blue and Post Code bit 6 is blue.

I don’t know what the Post Code bits are saying. I am stuck here and I don’t know what to do.

Any help to diagnose the problem and fix it asap would be appreciated. Especially as this is my everyday laptop.

I wanted to add that connecting it to an external display did not work or rather, did not change things at all. I still couldn’t see anything on either screen (internal and external).

Resolved the problem by changing the SSD, something about the SSD was screwed up. Upon changing SSD with a new one and using a bootable USB, the computer started purring along like normal…

Now, I will have to see what is wrong with the old SSD and see if I can retrieve the data from it.

Could someone mark this as RESOLVED?