FrameWork stopped booting

After months of flawless hardware performance, my Framwork stopped booting last night. I checked memory modules (allowing for plenty of time to memory train), reset the motherboard, and still can’t even get the Framework logo to appear on the screen. There were no drops or unusual handling moves between the last successful boot and last night. I submitted a request from tech support, but would welcome any additional suggestions.


Have you tried these steps: My Framework Laptop is not powering on ?

Have you tried carefully removing the RTC battery?

1 Like

I don’t actually own a framework laptop (though someday I hope I will.) Here’s a few general troubleshooting tips though.

  1. Hold down the power button for 30 secs. Then attempt to power up the laptop. This will reset your EC (embedded controller/smc)

  2. Open the laptop and disconnect the battery (thanks framework) then do the same thing.

  3. Open and close the screen several times. Then press power. Sometimes the firmware thinks the lid switch is closed when it’s actually open.

  4. Note: When you get your laptop back up. You may want to attempt a firmware/bios upgrade. This is likely more stable than what your laptop shipped with.

Thank you for your suggestions. I’ll bookmark this page. Still not even getting the logo to come up. When I do get another boot, I will update the firmware.


I’ve gone through the power up and resetting, and I made the mistake of pushing my luck with the lithium cell again. Yes, you DEFINITELY need to be careful. It’s a shame. I loved this laptop.

@Stan_McIntosh what happened to your machine in the end?


For now, I’ve given up. Didn’t hear back from tech support. The suggestions didn’t work. It’s a shame. I’m not a laptop person, but I loved my Framework.

1 Like

In a similar situation. Everything was working great until last night, opened my Framework from lid being closed and now screen doesn’t come on, but keyboard lights and green lights on the side. Tried troubleshooting above, no luck.

It goes through a restart cycle over and over again.

1 Like

I’m sorry to hear that you’re having issues with your Framework! Could you please DM me your ticket information? Our response time is around 1-2 business days currently so if it’s been beyond that, we would love to look into it for you :orange_heart:


Oh, no! I am so embarrassed that I don’t know what to say. I did fill out a request, but apparently not fully. There is no record of a ticket in my e-mail, so I obviously messed up that part. Thank you so much for your response, and I will address the ticket now.

I’m also frustrated at myself for fumbling the lithium cell holder. I had no trouble the first time, but then the holder came from the motherboard the second time. Will I most likely need to get a motherboard replacement now? Maybe I can resolder, though usually I (strongly) prefer working on through-hole rather than SMT.

Regards, and please accept my apologies.


1 Like

I hope they switch to a more robust battery holder in future revisions. Repairability is nice, but robustness is also important.

You might get this exchanged by the Framework team who are hopefully able to resolder a new battery connector. Or you go to an independent repair shop, although I have no idea if there are any that specialize in Framework laptop repairs.

I love not only this laptop but this company and community. Once I calmed down after the frustration and reached out for support (properly submitting a support ticket this time), FrameWork gave instant relief.

1 Like