Framework 13 touchpad sticking up

Anyone have any ideas on how to fix this? My touchpads been like this since I got my framework 13. If you look closely at the pictures you can see that its starts off normally then sticks up a bit before going back down on the right side. One pic is the keyboard on a flat surface the other is on the laptop.
Here’s everything I’ve tried so far:

  1. I opened up my laptop and my battery is fine (not pregnant)
  2. I took the touchpad completely out and put it back in again
  3. I laid it on a flat surface to make extra sure it had nothing to do with my battery (even though it looks fine to me)

Any help would be appreciated sorry if I’m in the wrong place this if my first post. Just wanted to see if anyone here could help before I bug support about it


2 Likes

I had a similar problem with my FW13 (AMD Batch 2). The touchpad was too high on the lower edge, fine everywhere else. Furthermore, there was some pre-travel before a click registered. It was like that from the beginning and didn’t bug me at first, but I decided to see if I could fix it, anyway.

My solution (proceed at your own risk, I don’t know if this solution has any side effects) was the following:

  • I removed the touchpad (see Touchpad Replacement Guide - Framework Guides, until step 10). I skipped step 5 and instead removed the input cover cable from the mainboard, so I did not have to glue it back in later.
  • In the lower half of the touchpad, there are two metal tabs sticking out to the sides. They are the “end stops” for the touchpad. There are two corresponding pockets on the input cover. I carefully placed some layers of Scotch tape in these pockets.
  • Put everything back together. The touchpad should now sit a little bit lower than before.

In my case, 4 layers of Scotch tape were just right. The touchpad now sits a little bit lower than the input cover and all pre-travel of the touchpad before a click occurs is eliminated.

If necessary I can take some pictures tomorrow, but right now that’s not an option, because I’m typing this from the FW13 in question :wink:

1 Like

I would not mind some pictures, my touchpad is also having similar issues.

Here you go. A picture of the input cover from inside, the touchpad is at the bottom. The tabs I was talking about are circled in red:

And here are two detailed pictures from the tabs and the pockets below. It is barely visible, but there is scotch tape in the pockets below the silver tabs.

I hope that helps :slight_smile:

2 Likes

That worked like a charm!

Clicking the bottom left now actually feels like a “click”, and the touchpad now slightly lower than the keyboard cover/frame around it.

2 Likes