Framework Laptop 11th Gen suddenly died

Today my Framework laptop seemingly died. All of a sudden, the screens (one external and the internal went black without warning), fans might have been kept on running though and the power button was illuminated.
Since I was in a customer appointement at that time I rushed to get it working again (which in hindsight might have made things worse), so I tried to reboot it hard by holding the power button down for quite some time.
After that it did not reboot, but did nothing anymore. It does not boot, it does not even show some of the uefi stuff or a logo or anything, not even the backlight as far as I can determine.

Current behaviour is the following:

  • If I press the power button it gets illuminated for a short time and then goes of without any further action
  • If I press the power button again after that, it stays illuminated for about 30s and in that period the blinking LEDs tell me that some of the checks fail including the CPU S0 state if my count is right

Steps I took:

  • Trying to power on without the power cable, without the battery, without the CMOS battery and several combinations of that including all of them in the hope of draining some residual potential - no result
  • Removing all the USB modules - no result
  • Remove memory and storage - no result
  • Trying to boot with a USB stick with the update for the UEFI shell on it, no result, but I am not sure I the setup of the USB stick was correct, no reaction at all in any case

My best guess so far:
For some reason my operating system (Debian GNU/Linux with a mix of testing and sid packages) tried to install a firmware update during runtime and I chocked that off in my panic to get the system to work again. So now the firmware is a broken state and fails to initialize correctly. This is only a guess and I do NOT have real proof or even clues in that direction,.

So, does anyone have any ideas on how to fix this or some hints on to how to narrow the problem down?
Is there a possibility to flash the firmware “from the outside” withouth having a working version running?

I would be really grateful for any help on this matter.

1 Like

Contact support ASAP. Not only will they want to investigate how this happened to avoid it occuring for other users, but they will be best equipped to help you resolve this issue. I wish I could offer more help, but I don’t think I’ve heard any reports of something like this happening before. Best of luck!


Just yesterday I had exactly the same behavior, at least I think I did. Happened when I was just using the laptop lightly. Totally bricked device and I have tried all that you have done as well. My machine is running Windows

I think your laptop may be booting, but that something has happened to totally screw-up the display out. When I turn the power on my device will connect to my bluetooth headset despite not even a backlight. The external monitor I have been troubleshooting with detects a signal but it is just a black screen.

Did you hear back from support?

Hi @Azure I did, thank you.

Hi @Cameron_Winterink , I did but they mostly let me re do all the stuff you find in this forum (resetting the mainboard, trying other ports, removing the modules, etc). Nothing really changed so far, sadly.