Framework Laptop DIY Edition not turning on

I just received my build of the framework laptop (DIY Addition). I have installed every part of the laptop and tried turning it on. Upon discovering that it wouldn’t turn on, I had left it to charge. After a charge, it still won’t turn on.

How do I go about resolve this issue? I am kinda bumbed out at the moment.

I just renamed this thread title “Framework Laptop (DIY Edition)” to “Framework Laptop DIY Edition not turning on” adding the “help” tag, as I thought the title could be more specific.

1 Like

The laptop appears to be able to charge and turn on, but that is with all the RAM, storage and wifi out of the device. Full assembled, it doesn’t charge nor does it turn on.

In both instances, there isn’t any image on screen. The un-assembled state has the fan spin up when attempting to turn on however, but again there isn’t any image displayed.

Some more details about the components you chose might help others help you, and how much experience do you have with building computers?

Is there any way that I could send it in? You guys at assemble and ship it back out? The problem seems to lie in the assembly. The DIY Addition un-assembled is able to charge and turn on (with no image displayed)

Also, one of the tabs holding in the button cell broke off. I don’t think it’s a huge issue for the button cell slot to be empty. Would there be a problem without a button cell in the device?

The components that I chose:
intel® Wi-Fi 6E AX210 vPro®
64GB (2 x 32GB) DDR4-3200
Power Adapter - US/Canada

MicroSD Expansion Card
USB-A Expansion Card
USB-C Expansion Card
HDMI Expansion Card

That is a problem. The button cell is rechargeable and not only retains the BIOS (UEFI) settings and the clock, it also seems to control charging.

You should contact support:


Yea I am currently In talks with support. I was just getting more eyes on my problem.

I was going to ask if there were any LED sequences on the side LEDs, they give some boot process diagnostic info:

Were you getting any flashes before the coin cell holder broke? Are you getting any now?

Even with the button cell, the laptop wouldn’t turn on. That time, I had all the components installed. No signs of life.

It is when I had disassembled the laptop back to the delivery state where it showed signs of life. Charge port light came on (orange, which I assume is just a charge indication) and I was able to turn the laptop on, all be it with no image. Only fan spin.

I am now waiting on instructions to send in the main board for replacement, but framework support said that they would get in touch with me shorty. That “shortly” has been over an hour and still no reply. What is the duration on that “shortly”?

Alright. I think I am getting somewhere. As I can’t get a solid communication with framework, I am trouble shooting myself.

The problem seems to lie with the keyboard. When I plug in the keyboard, the charge light goes out and when it is off, the charge light is green.

I have the RAM In so far, the charge light is still solid green.
M.2 in, The light is still green.
All the HIDs are in, light is still solid green.
The Wifi module is in, the charge light is still green.

Really doesn’t matter in the long run, still need the mainboard replaced for that broken button cell pegs and keyboard. I have the button cell taped on for now.

How do I turn on the laptop without the keyboard?

Yea the issue is the keyboard.