[SOLVED] Laptop will not turn on unless plugged into AC power

Hello everyone. Thank you for coming to help. And if you are here with the same problem, I hope you find a solution in this post and the replies.

I recently bought a Framework Laptop. It arrived May 12, 2022. I purchased the DIY version, as I want to learn more about building laptops, and putting together one, but all components were purchased from Framework in the create your laptop page. I got the Core i5 mainboard, with the non-pro wi-fi. I got 8GB of RAM, on a single RAM stick. I also purchased a 1TB SSD from framework as well.

When I put the computer together, It would not initially turned on. Following the setup guide provided by Framework, (Titled “Framework Laptop DIY Edition Quick Start Guide” ) I noticed that the ribbon connector to the Input Cover was not connected properly. Additionally, some of the golden pins on the Input cover had come off. This appeared to have been damaged in shipping, and as a result, I could not turn on the laptop, or use it.

I contacted Framework support and they were super helpful in sending a replacement right away. I received it on May 26, and it worked without issue. The first things I did were install the Framework Drivers, and update the BIOS. I didn’t have, or at least didn’t know of, any problems yet, so I wanted to update to the newest firmware just to be safe.

After updating I used the computer for a while without problem. Later on, after shutting it down when I left home, I returned to power it on only to find that I was unable to. The laptop would not turn on on its own power. I plugged it in, thinking it might be dead, and this time it turned on. However, when it booted, the laptop was at 79% power. Not dead. I turned it off and unplugged it, and again, it wouldn’t turn on.

Once I turn it on, it stays on. I can unplug it, and take it to the other room to work on it, no Issue.

I searched around, and found a few threads about others having the same problem. (This thread in particular: Laptop won't power on unless i plug in AC power)

Following some comments in that thread, it sounded like the RTC battery (Also known as the CMOS Battery) was the problem. I had a friend who knows a lot more about computer repair than me come over to help, and we got to work diagnosing the problem.


We found that the RTC Battery was perfectly fine. It was connected properly and securely, the pin under it didn’t need to be bent up, and we even got a reading on our multimeter when connecting to the solder points, showing that it was indeed transferring power to the Mainboard.

My friend checked the full battery next, the Lithium-Ion one. Thinking that maybe it wasn’t connected right. We found that while all the pins had power, the motherboard was not receiving power on all pins.

While moving between the pins to test them all, we accidentally connected the 3rd and 4th pin with the probe of the Multimeter. Low and behold, the laptop instantly responded. The red incase lights turned on, and once we reconnected the ribbon connector for the Input Cover, it booted right up, despite not being plugged in.

We focused on this point, and while we found that the laptop would turn on, we could not find why this was happening.

Since then, I have reached out to framework support, and they have been diligently helping me in trying to fix this. I followed their advice, first making sure that the laptop was charging for 24 hours, incase the CMOS battery was too low on power and wasn’t functioning.

Then, sent pictures showing the connection, so they could ensure that it wasn’t just not connected. A support member then advised that I plug the laptop in from 2 areas. One from its main AC Power adapter, and another plug from a USB-C phone charger on another port, saying that this can cause it to trickle charge the RTC battery too.

Both of these solutions were left for 24 hours to charge, but it still didn’t work.

Today, I sent an email to Framework support advising of everything, as well as providing a video of me explaining and showing the laptop, the problem, and what my friend and I found. I am providing a link to the video below. It is uploaded to YouTube.

I know that they are closed today, and don’t expect an immediate response. I know they have a lot of work, and have been very helpful.

The reason I am making this post is for a few reasons.

  1. If anyone else has the problem, they can share that point here, as well as share more that they found in their own Diagnosis.
  2. Should we find a solution, I want to have it posted online for others to find if they have the same problem.
  3. More minds working together are better. Someone here may have an idea that Framework Support hasn’t thought of yet, that works. You never know.

I am hoping to find a solution, as I love the concept of the Framework Company. The right to repair, the openness, and the actual Customer Support team make me want this company to be able to compete with the big name tech companies. Force them to do better to meet the competition, or step down and let Framework take the stage. I don’t want to cause problems, or just ask for a refund and return the laptop. I want to support Framework how I can, by being a customer. And, with the community help being what it is, I am hoping to find more help here too.

Thank you for reading. If you have more questions, I would be happy to answer. Please, also watch the video linked below, as I explain everything verbally there, as well as show exactly what I am talking about and mean.


Have you tried a full mainboard reset?

1 Like

Any fix to this yet? Mine is doing same. Must plug in a USB-C to turn on, even with full charge.

@mjnz I suggest to open a support ticket.

If this is a fault or bug with the 11th Gen mother board with the intel chip, then it is not fit for purpose and should be replaced under warranty.

1 Like

Hi and welcome to the forum.

There may well be a fault with the Intel chip, which has only become apparent as Framework didn’t have the CMOS/RTC battery recharged from the main battery.

So thanks to Framework the Intel bug has been discovered, but I doubt Intel will replace your laptop and as Framework was not aware when designing then they cannot be help responsible for the use.

Anyway, there’s no ‘should’ unless you want to be an authority.

Best option is to do what you consider ‘good’ for you and leave Intel and Framework to do their bit.

You can of course communicate with each and spend even more time than resetting the board and getting a new ML1220 if you have ‘trashed’ it by your use strategy.

Note there is supposed to be a guide on a hardware fix, I wonder how that will go down.

Meanwhile my use is every day for hours and the problem hasn’t hit me yet

Well yes i wouldn’t expect much help from a US company like Intel.

Yes and that could be carried out by Framework if they had the resources to challenge them, and if they don’t . . .

I’m now hitting this. It’s not clear to me if there’s a known solution? I thought from the other mega-thread that it was only an issue if the RTC battery drained over a week or so. This happens to me daily now, if I leave the laptop unplugged overnight

1 Like

If you charge it for 24h and it still continues to happen within 6-8 weeks, that means your RTC battery has been deep-cycled to the point that it will no longer hold a charge. If you contact support, they will send you a replacement RTC battery, free of charge, regardless of warranty status.

Alternatively, if you have advanced rework skills or a shop that you trust to do board-level reworks, there is a rework available that adds the ability for the RTC battery to charge from the main battery.


I never posted a fix here.

I contacted Framework Support, and they were able to help me identify the issue. It was the mainboard itself. It had a faulty CMOS (RTC) Battery socket. The actual socket that connected the battery to the board, and the portion of the board it was attached to, were faulty. They had to send me a new mainboard to install.


It was an easy install, and like always, the Framework videos and guides were super clear. Another thing, the support team didn’t treat me like an idiot. I did a lot of diagnosing myself, and it helped confirm the problem. They never doubted my results from my diagnosing, and even asked me to perform a few additional tests to ensure we had it right. When changing everything, they never spoke to me like I was an idiot, or was a first time buyer.

They treated me as an equal, as an intelligent human being. Most of the time when I speak to customer support with a tech company, they treat me like a 40 year old middle aged mother who barely touches a computer. “Have you turned it off and back on?” “Is it plugged in?” ETC.

But, Framework, they just jumped straight into it. None of the standard BS. I provided the information I had, they asked for more, and helped guide me how to test when I asked them. Their guides were simple and easy, and completely enjoyable to watch. When I received my new mainboard, it got damaged in shipping. It was SEVERELY warped. Literally was arched. If I laid it flat, the middle stood almost an inch off the table.

I contacted Framework, and there was no bs. They just issued a new one, and asked I return both my original broken one, and the one damaged in shipping. The entire process was pleasant, smooth, professional, and made me feel more valued as a customer by a company than any other tech company I have had the displeasure of having to speak to before.

I am so glad I chose this company, and will continue to choose them for a long time.

No, I was not paid to make this comment, or was I encouraged to do so. I got an email notice in my inbox of people asking if this problem was solved, and decided to gush about how much I love the company, as my family is tired of hearing me talk about Framework now and I have no one to talk to about it.


So, is it conclusive that so many of my power-related issues are related to this RTC battery? I pre-ordered one of the Ryzen motherboards, and I’m so eager to get it to fix the issues with this 11th-gen Intel Nightmare and its abhorrent quantity of power-related issues, my blood itches.

One of my numerous power-related issues with my i7-1165G7-based Framework is that, when it’s been left for a long time, it’ll just… not turn on until I plug it in. Then, I plug it in, unplug it, it boots, and it has more than half (or a full!) battery left. No reason it needed to be plugged-in. But, among the sea of other problems (e.g. battery drains to zero in sleep in hours, unless I fully shut-down the computer, and plugging-in USB tends to wake it from f*cking Hibernate with no recourse to stop that behavior), this power-related issue just blends into the background.

I’ve just not been able to find any conclusive “why” in the threads I’ve read - the answer is buried somewhere in the hundreds of replies.

Yes it’s the RTC|CMOS battery. It can degrade if not kept well charged. It can only be charged form the mains, so if left unplugged a lot it discharges. If this happens 100 times it will not last a couple of days and then the laptop won’t power on without a mainboard reset maybe.