Getting virtualbox working on 12th Gen Framework in Ubuntu 2204

OK, I confess, I was honestly expecting VirtualBox and VMware Player to just install and work. Hah!

I am running on a new 12th Gen Framework with the i7 1280p and 32 GB RAM. In general, Ubuntu 22.04 installs and works fine. I do have some flickering mouse issues, but I will sort that.

I have a lot of experience with VMware Fusion and Parallels on Apple Mac. Everything I read about virtualbox was positive.

I installed virtualbox 7.0 - newest version. It said it installed fine. Then I installed the extensions since it seems that virtualbox is almost useless without them.

Several kernel modules said they required to be signed. I tracked down how to sign them and was mostly successful, then I read that they must be resigned whenever the kernel is modified. Well, I see the kernel getting updated pretty often, so I simply turned off Secure Boot in the BIOS and the kernel modules problem went away.

I will not list every tweak it took, but there were many to just get Windows 10 running. I had to track down how to make the microphone work, same for the mouse/trackpad. These did not work “out of the box”. Overall, it took me about two days to track down all the glitches, find some posting that really fixed them and make it all work.

All of this surprises me a bit. Mid project I tried to just switch to VMware Player - exact same issues. Kernel mods, needed a lot of config to start, failed to install Windows 10. So I went back to virtualbox and made that work.

At this point, I have a 100% working system with one kludge, if I want the camera to work, there seems to be no static setting to do so (if you know of one, please educate me - I am teachable).

So, when I start virtualbox and Windows 10, if I want the camera to work, I have to attach it AFTER the Windows OS boots. I run this from a shell script from the Linux side to attach the camera (for every Windows 10 boot session)

# See the list of cameras
# VBoxManage list webcams

VBoxManage controlvm "Windows10" webcam attach /dev/video0

I am actually pretty happy with my overall system and setup. I have switched from “installing and configuring” to just working every day. My original plan was to use the Windows 10 OS to host Zoom and Teams (which I am forced to use by some business needs). But the screen sharing only works inside the Windows 10 display (which makes sense to me.) So I have tweaked both Zoom and Teams to work on Ubuntu. Zoom froze on me several times until I found this work around to turn off the GPU when Zoom starts (another shell script)

zoom --disable-gpu-sandbox &

All of this was a lot more obscure than I was expecting. I watched several YouTube videos on installing virtualbox and none of them showed any problems. But my install path required many separate small issues to be solved with some configuration fix that was not easy to find.

Now, to be 100% clear, I don’t think ANY of these issues are related to the Framework laptop; I think they are all related to running virtualbox on Ubuntu 22.04 on modern hardware (with, for example the UFEI secure boot turned on).

I am super happy with my new dev environment and I have now stopped using my MacBook Pro. I have switched to a Linux environment for my daily driver. I very much like the Framework machine.

The biggest upside shock? I bought the 1TB storage module. I just copied 3.5 from my main drive to the 1TB module. I thought it failed because it was so quick. The module was pricey ($140) but it is wicked fast.

I think VMWare player should work which just require patching the kernel. I could check for you regarding the install process as there’s a tiny workaround from my experience.

Regarding Teams and Zoom, there are linux native apps for both or even web based, have you looked at them?

@Jieren_Zheng I am using the Linux native apps for both Teams and Zoom. The patch above is for my Linux Zoom app (run it with the gpu disabled or the screen was freezing). Of the two apps, Zoom is the better behaved. Teams is a big, heavy app. And it is cumbersome to login (several steps each time). SO I let it run in the background (for now).

ALSO: I could not make Google Meet work! There may be a better method, but I switched X11 from Wayland to Xorg to make Google Meet work. (That one also surprised me).

I would love to always use “web based” but I must share my screen often and my experience is that I need to use the stand alone app, not the browser version for Zoom and Teams.

At this point, I am expecting to only need Windows when I must use “real” Excel. I have gotten pretty proficient at using Libre Calc - not a bad application. But there are some things that only native Excel supports. My hope is that I seldom run Windows 10.

1 Like

Agreed, Zoom is better behaved, I do notice if I keep it open for long it freezes for me.

The last time I used Teams, functionality was sorely lacking.

I have only ran Google Meet on Xorg, didn’t expect Wayland to break it. Now I am worried as I have an interview tomorrow.

Yea, for more features the web based are sorely lacking.

Agreed on the limitations of Libreoffice, I kinda wished we have a feature parity equivalent for Excel and Powerpoint, Libre Calc kinda gotten better but I have quite a few instances where I realise I couldn’t do this and that for work. Impress is really bad. OnlyOffice is kinda just better compatibility with the new xlsx/docx/pptx but features is almost on par with the web office which is kinda useless if you are using for work sadly.

Microsoft Office 365 online is useless. Missing major features, limits to file sizes, just a weak product for serious use.

I tried OnlyOffice. Lots of promises, but like you said. Frankly, after a lot of poking, I am sticking with Libre Office, and I am willing to pay money. But to me, the only practical options are to use Libre Calc for 75% to 90% of work and have real Excel on some machine (or vm) as a backup.

Do test Google Meet ahead of time. I was really surprised because I was using Chrome!!!


1 Like

Out of curiosity, any reason that you didn’t use kvm/libvirt? If you are bored and want to go back down the rabbit hole, you might fiddle around with that some.

1 Like

@lbkNhubert just less coverage on kvm, and I did make virtualbox work finally. I may try kvm on another machine.

1 Like