[Guide] Install Intel Wireless Drivers on Linux

@MikeCH - there’s a lot of useful info in the thread linked in by @Foxtrek_64, but ultimately if you’re still having issues my guess would be that they were due to the driver support for the card in linux not yet being mature.

1 Like

also if you still have issues where wifi doesnt show up but bluetooth is working, you will want to either make sure to either delete or rename iwlwifi-ty-a0-gf-a0.pnvm to iwlwifi-ty-a0-gf-a0.pnvm.bak

Original Source is unknown, but response by DrTor is what helped me fix this issuea source of info

1 Like

Hello everyone, in my case it worked for me to execute the following commands

sudo apt update
sudo apt install --install-recommends linux-oem-20.04d

2 Likes

@Shaun_Reed’s solution is what worked for me after trying numerous things. As stated by jay and KOSTYANTYN_RUKHLIS, if you are running 20.04.3 LTS, this is the additional, final step needed before the reboot apart from OP’s instructions: sudo mv /usr/lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm /usr/lib/firmware/iwlwifi-ty-a0-gf-a0.bak

Thanks for the information everyone!!

EDIT: I spoke too soon, essentially this first solution makes the WiFi option appear in the network manager, but failed to successfully connect to any WiFi (though it could measure the strength of the signal). It was @Joelvin_Chirino’s solution that allowed the WiFi connection to go through successfully.

Thanks a million everyone!!

I have funny one, I am installing KDE Neon and I have working Bluetooth, but WiFi is not detected.

1 Like

Today after the latest update, my wifi stopped working in Linux, but still worked in Windows 11. I followed the guide and the later notes to copy the file iwlwifi-ty-a0-gf-a0-59.ucode from the directory from the tarball to /lib/firmware. I restarted a few times and the system did not appear to recognize that there was new firmware to install: I checked /lib/firmware for all files that matched iwlwifi-ty-a0-gf-a0-59*, and there was only the file that I had copied to /lib/firmware. I tried shutting down and booting, and that did not bring wifi back. I ultimately shut down and then pushed the power button for about 10 seconds to shut it down even more (?), and then restarted the machine again, and it was after that that the system apparently recognized and installed the new firmware. Now there is a file /lib/firmware/iwlwifi-ty-a0-gf-a0-59.ucode.xz that had not appeared after my previous restarts/reboots.

2 Likes

@Jeremy_Schneider I have the same problem and I can’t make it to work. Yesterday everything was fine and at the end of the day, I updated the system. I tried installing firmware for Kernels 5.2+, but still nothing.

This is so stupid, how tf is system supposed to download new driver after Kernel update when Kernel update breaks driver compatibility completely and this is the only internet adapter.

I just reinstalled the OS.

@Jeremy_Schneider, great tip! I also tried multiple reboots after adding the driver, but only the “harder” reboot of holding down the power button got it to finally work. Thanks!

1 Like

Today, I ran into an issue with the wireless driver. Somehow, there are 2 iwlwifi-ty-a0-gf-a0-XX.ucode in /lib/firmware: -59 and 63 version. When the computer starts booting with 63 version, the wifi disappears. My fix is removing the /lib/firmware/iwlwifi-ty-a0-gf-a0-63.ucode and reboot to force the computer to boot with -59.ucode.

Does anyone have a better tip to fix this? or should i stick with -59.ucode version?
Here is my kernel version:
Linux 5.14.0-1020-oem #22-Ubuntu SMP Thu Jan 13 18:22:21 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

I got my DIY today. I got everything up and working, Including the wifi over my lunch break. Installed Fedora 35. Updated my system. I turned it off because I was starting work.
Work ends and I was all excited to jump onto my machine …alas no Internet. WIFI adaptor not found. So I figure I did not get the wires on quite right or something was loose. I do it two more times… Nothing. Then I found this but I am not able to get the driver I copied to install in /lib/firmware/ I am not sure what I need to do here. I did confirm that my issue is the driver. I booted to the live disk and SHAZAM! I have wifi. Any suggestions?
thanks,
Pete

I am just going to reinstall Fedora from my live boot disk. It is less time. I had not installed any software.
Update…Install done in like 5 min! wifi is back.

If others go this route… and want to update system without updating the kernel:
sudo dnf update --exclude=kernel*

I tried this, but still no wifi. My wifi works fine in 5.13, but not at all in 5.15. (However bluetooth works in 5.15 but not 5.13).

So…
I reinstalled 5.15.19-1-MANJARO (no wifi) and found the following in the boot log (journalctl -b 0):

kernel: iwlwifi 0000:aa:00.0: Loaded firmware version: 66.f1c864e0.0 ty-a0-gf-a0-66.ucode

kernel: iwlwifi 0000:aa:00.0: Failed to start RT ucode: -110

I moved iwlwifi-ty-a0-gf-a0-66.ucode to iwlwifi-ty-a0-gf-a0-66.ucode.bak and rebooted. The system came up with wifi working. Looking into the current boot log:

kernel: iwlwifi 0000:aa:00.0: loaded firmware version 63.c04f3485.0 ty-a0-gf-a0-63.ucode op_mode iwlmvm

Bluetooth is also working.

1 Like

I also managed to fix it, but I honestly don’t remember what I’ve done. I know that I moved all .pnvm files to .bak and after some reboots it worked. KDE Neon, btw.

Edit: I mean, I can check my bash history.

1 Like

I downloaded the driver file mentioned by the OP and looked at was in it.

iwlwifi-ty-a0-gf-a0-59.ucode

Then I looked in my debian bullseye /lib/firmware dir and saw:

iwlwifi-ty-a0-gf-a0-59.ucode
iwlwifi-ty-a0-gf-a0-62.ucode
iwlwifi-ty-a0-gf-a0.pnvm

Seems like debian bullseye comes with the required firmware? Maybe it’s a matter of how to force the correct driver to be loaded?

1 Like

Wifi wasn’t working for me on Manjaro with Kernel 5.15.41-1.
I used the steps described in the original post, but it still didn’t work after that. @Richard_Tango-Lowy 's solution helped me out though. using dmesg I looked at the boot log:

sudo dmesg

I found the same error message as described in his post. I then removed firmware version in question:

sudo mv /lib/firmware/iwlwifi-ty-a0-gf-a0-64.ucode /lib/firmware/iwlwifi-ty-a0-gf-a0-64.bak

followed by a reboot:

sudo reboot now

I had to repeat this process of looking up the firmware version causing problems 4 more times, until one of them (ty-a0-gf-a0-59.ucode) finally worked.

1 Like

Glad to be of service ;- )

1 Like

@Bart_van_der_Heijden

Hi, Bart. Thanks for writing up your solution with an explanation. It worked. A different file causing the problem was causing the issue for me as well so I ran the following instead:

sudo mv /lib/firmware/iwlwifi-ty-a0-gf-a0-66.ucode /lib/firmware/iwlwifi-ty-a0-gf-a0-66.bak

The best way to solve this problem without any headache is : just install a new linux firmware after deleting it first , it’s just somewhat 100 to 200MB , it will automatically get you all the required new files and will fix the bugs as well.

remove linux-firmware

sudo apt-get remove linux-firmware

reinstall linux-firmware

  1. check for update if update is there do upgrade first.
sudo apt-get update
  1. install linux-firmware
sudo apt-get -y install linux-firmware

Ideally one should not be editing the files from the firmware because they are managed by the distro provider in very systematic way, if you remove somefile somehow by mistake then it may happen that some other hardware may not work. so I will suggest reinstalling a small firmware file’s entire package is a good way rather than brainstorming for this problem of driver not available.

1 Like