HDMI Isn't working

Hey all! Enjoying my laptop. Got the HDMI module so I can watch things on my 55" tv. But the laptop isn’t detecting the TV or a second display… NEW HDMI cable… checked it out with my blueray just to make certain that the cable is good. I’ve updated the Intel drivers, no change. Is there s setting somewhere I need to change? Thanks in advance!

@Kenneth_Gilbert have you tried unplugging/replugging the card or swapping ports?
Also does it show up as a removable usb device as HDMI Expansion Card in Windows.

Is this problem on Windows or Linux? I swapped in my HDMI module for the first time a couple of days ago. I’m running Fedora 35. It was a hot swap; I thought I might have to reboot but to my surprise it just worked and immediately recognized the projector to which I was attached. Perhaps check to see if the module is well seated?

1 Like

Actually, it started working. I rebooted twice, no change. Turned computer off for an hour, brought it back online and it said something about configuring the HDMI adapter and boom!


I am having trouble with hdmi and recognizing a second monitor in general. tried uninstalling and reinstalling drivers for ports and graphics, nothing worked. Did manage to get it working with a USB-C monitor but only with the usb-c power cord that came with the laptop. Can not cast to another screen wirelessly either.

I had a problem yesterday where my HDMI stopped working on EndeavourOS (an Arch Linux variant) using kernel 5.15.2. Booting to their LTS kernel (5.10.80) fixed it. Actually, looking through my logs, 5.15.2 was working originally, so something else I updated after initial install must be at fault. Booting LTS does fix it, though

1 Like

I messed up my fedora system and decided to do a clean install. Everything is working except my HDMI is not recognized. So I can’t see my second monitor. It worked fine before so I think it is missing a driver or something. I have rebooted a few times but did not have the luck Kenneth did. :frowning: any help would be appreciated.

lsusb finds: Bus 003 Device 002: ID 32ac:0002 Framework HDMI Expansion Card
so it looks like the card is working…

found a link to a guy who solved a similar issue…

I run glxinfo | egrep “OpenGL vendor|OpenGL renderer”
OpenGL vendor string: Mesa/X.org
OpenGL renderer string: llvmpipe (LLVM 14.0.0, 256 bits)

my system has the Intel i7-1165G7 processor which has integrated graphics.
I need to do more research to see if this is my problem or not.

So without any participation or support from the vendor :frowning: I decided to test what would happen if I ran Fedora live…Bingo…HDMI works. (In fairness I did not try official support channels and this thread is pretty old so that is on me).
Looking at the settings from glxinfo I get:
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) Xe Graphics (TGL GT2)

I am thinking it is the same issue as 9to5 Linux posted.
Now how to fix it…

Update…This is solved for me. I could not figure out how to change the settings…Wasted a half a day researching it. I solved this by just reinstalling the OS (Fedora 36) from scratch and got it working.