Hot fingerprint/power button

Hi all,

After just a couple of days with my new framework I encountered an issue. It could be that I generated this but I would like to know if I can fix this.
My power button/fingerprint reader is really hot (65ºC) and it’s unusable.

This issue started just after I used my Lenovo USB-C 7-in-1 Hub with a 65W power adapter connected.
Until today I only used it only to connect my monitor to my frmwk, while the power adapter was connected directly to my frmwrk on another port.
Although the lenovo hub specifies that it supports the power adapter input I don’t think that the it’s supported by USB-C expansion cards.

Right after my stunt here with the power adapter, my frmwrk seemed to have shut down :scream:.
Initially I thought that I caused a short circuit on the motherboard, but after a few attempts I managed to restart it :relieved:.

Only after this restart I noticed that the fingerprint reader is getting really hot, and I cannot even keep my finger on it for more than 1s. I should mention that I can start and stop the laptop by pressing the power button.

So my conclusion is that the power adapter managed to short circuit something in the fingerprint reader.

I also noticed that the touchpad is a little hot in the top right. (While checking the connections on the inside I noticed that there is a connection between the power button and this top right part of the touchpad).

Right now the only thing I can think of is to order a new fingerprint reader. Could take a couple of days, since I noticed that it’s only available in UK, while I’m from Romania (might get some friends to help me with this :grinning:)

What I’ve tried so far:

  • disabling the fingerprint reader from BIOS doesn’t help
  • since I use fedora, I enabled hibernation which will be triggered by the power button. Luckily it’s a short press that will help me shutdown and close the lid while the finger print reader will cool off. Otherwise, with suspend, the button will still be hot and it could affect the display while the lid is closed.
  • I’m thinking to enable from BIOS wake on power and physically disconnect the fingerprint reader so that it doesn’t heat up anymore. This way I can start the laptop just by connecting it to power. Also I’m not sure if this heating problem could affect other components, so this solution could help me with that.

If anyone has other ideas, feel free to share them. Maybe we can find a better solution to fix this.

1 Like

Please contact support about this if you have not already, this is definitely not expected, and I know that support will want to know what’s going on in order to help anyone who has an issue like this in the future.


Can you confirm that you installed all drivers for the Framework. If I remember correctly, the fingerprint reader will heat up as you are describing if the driver is not installed or crashes. Since you are using a form of linux, I’m not super familiar with how to install the drivers or what packages you would need, but you can check this topic for more info on that.
Fingerprint scanner compatibility with linux (ubuntu, fedora, etc) - Framework Laptop / Linux - Framework Community

1 Like

I did notice that the fingerprint gets really hot but only in the bios.
Did you check the power adapter for any damage? I don’t have another explanation for how it could have short circuited(but that should have made other issues as well) the framework.
Btw, how did you ship it to Romania? Mine was shipped by a family member

On linux, drivers are already installed(that is the case on all distros I used on my framework) so that is 99.99% not the issue

After checking a bit further, and filtering my search for Fedora on Framework specifically, I found this.
Fedora 34 on the Framework Laptop - Framework Laptop / Linux - Framework Community
It would come down to how Fedora is installed, as there are methods of installing this distro, where the fingerprint sensor will not function properly.

1 Like

I looked into this issue as well, but it’s not the OS.

I use Fedora 36 and initially it worked ok. Since I installed some updates on fedora, I also tried using the initial live USB from which I installed it, but it’s the same behviour.
Now I also tested by starting in BIOS, and I get the same high temp on the button.

I had it shipped to a friend in Germany :smiley:

1 Like

First, the bios will not load the driver for the fingerprint sensor, so to my understanding, that is expected.

It’s good to know that the fingerprint sensor was working at some point. It’s possible though that the updates broke driver compatibility for the sensor.

I totally missed this detail when I posted my comment, and unfortunately this would make contacting support to help you a little more difficult. Sorry for the less than helpful advice…

I think it should be ok, I can still use my friend’s address in Germany, if it comes to any shipping issues.

1 Like

I also have a hot power button sometimes. I wonder if it’s related to my 50%+ per 24 hrs of sleep battery drain.

In the end with a lot of emails back and forth with support, they are sending me replacement components. :tada:
Actually to my friend in Germany :smiley: