FW13 Fingerprint reader broken after USB Short


What Happened

Tried plugging in an Arduino Uno into Left Front port

  • Laptop screen immediately turns black, and it becomes unresponsive
    • Tried pressing/holding power button multiple times but will not turn on
    • After waiting for ~2mins turns back on and boots up
  • Fingerprint Sensor/Power Button is Extremely Hot
    • Login screen no longer shows ‘log in using fingerprint’
  • Left-Front USB Port still works, but the fingerprint sensor does not
    • Power Button + LED still works

Tried Plugging Arduino into another computer

  • Arduino does not show up in the IDE, but the computer does not shutdown/overheat, or show any problems of any kind

Output from previous boots

  • OS is 6.8.9-3-MANJARO but it is most likely a hardware problem, since the fingerprint sensor got super hot.
  • -b -3 forces journalctl to read from 3 boots ago
$ sudo journalctl -b -3 | grep -i goodix                                                    
May 17 21:05:14 hunter-framework13 kernel: usb 3-9: Product: Goodix USB2.0 MISC
May 17 21:05:14 hunter-framework13 kernel: usb 3-9: Manufacturer: Goodix Technology Co., Ltd.
  • This boot was active all the way until today, right before the short circuit

Try reading from current boot

$ sudo journalctl -b 0 | grep -i goodix Produces no output (-b 0 forces to only read from current boot)

  • This boot started May 20, right after the short shutdown the laptop

Confirm with lsusb

$ lsusb                                                                                    
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 32ac:0002 Framework HDMI Expansion Card
Bus 003 Device 003: ID 8087:0032 Intel Corp. AX210 Bluetooth
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
  • Previously it wood show a “Goodix” fingerprint reader


  1. Why did the short circuit protection of the laptop’s USB ports cause the laptop to shutdown?
  2. Why did it fry the fingerprint sensor, but not the port the Arduino was connected to, or the power button/LED?
  3. Would replacing the fingerprint sensor with the FW13 Fingerprint Sensor fix it, or did it cause damage to the entire mobo?
    1. Left-Front USB Port is unaffected, just the Fingerprint sensor does not work

Probably best to open a case with Support. Is the fingerprint sensor still hot when the machine is on, and does the led around it still work? If it is still hot I am not sure that I would use the machine until I heard back from Support. Best of luck getting things resolved.

the Fingerprint Sensor is not hot when operating, every other part of the laptop works completely fine. I am just curious to why a short circuit would fry the fingerprint sensor, not the USB port.